Closed Bug 616676 Opened 10 years ago Closed 10 years ago

crash [@ nsHttpPipeline::GetConnectionInfo(nsHttpConnectionInfo**) ]

Categories

(Core :: Networking: HTTP, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 616591
Tracking Status
blocking2.0 --- beta8+

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: crash, regression)

Crash Data

It is a new crash signature that was introduced by 4.0b8pre/20101203 build.
It is #12 top crasher in this build.

Signature	nsHttpPipeline::GetConnectionInfo(nsHttpConnectionInfo**)
UUID	9be734cd-dcbc-4cb2-8cad-4a0172101203
Time 	2010-12-03 15:13:21.958757
Uptime	19508
Install Age	19508 seconds (5.4 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101203030309
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 9
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x0
App Notes 	AdapterVendorID: 8086, AdapterDeviceID: 2572
MSAFD Irda [IrDA] : 2 : 1 :
MSAFD Tcpip [TCP/IP] : 2 : 1 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD Tcpip [RAW/IP] : 2 : 3 : %SystemRoot%\system32\mswsock.dll
RSVP UDP Service Provider : 6 : 2 : %SystemRoot%\system32\rsvpsp.dll
RSVP TCP Service Provider : 6 : 1 : %SystemRoot%\system32\rsvpsp.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{77BC9B66-8BB6-4E98-981C-1342464E4270}] SEQPACKET 6 : 2 : 5 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{77BC9B66-8BB6-4E98-981C-1342464E4270}] DATAGRAM 6 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{BA05DF94-DA75-4230-A3A0-309E80088CFA}] SEQPACKET 0 : 2 : 5 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{BA05DF94-DA75-4230-A3A0-309E80088CFA}] DATAGRAM 0 : 2 : 2 : %SystemRoot%\system32\mswsock.dll
MSAFD NetBIOS [\Device\NetBT_Tcpip_{3D2835C8-1475-4

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsHttpPipeline::GetConnectionInfo 	netwerk/protocol/http/nsHttpPipeline.cpp:231
1 	xul.dll 	nsHttpTransaction::ParseHead 	netwerk/protocol/http/nsHttpTransaction.cpp:827
2 	mozcrt19.dll 	arena_dalloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4281
3 	xul.dll 	nsHttpPipeline::Close 	netwerk/protocol/http/nsHttpPipeline.cpp:527
4 	xul.dll 	nsHttpConnection::CloseTransaction 	netwerk/protocol/http/nsHttpConnection.cpp:648
5 	xul.dll 	nsHttpConnection::OnInputStreamReady 	netwerk/protocol/http/nsHttpConnection.cpp:1000
6 	xul.dll 	nsSocketInputStream::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:256
7 	xul.dll 	nsSocketTransport::OnSocketReady 	netwerk/base/src/nsSocketTransport2.cpp:1526
8 	xul.dll 	nsSocketTransportService::DoPollIteration 	netwerk/base/src/nsSocketTransportService2.cpp:687
9 	xul.dll 	nsSocketTransportService::OnProcessNextEvent 	netwerk/base/src/nsSocketTransportService2.cpp:551
10 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:590
11 	xul.dll 	NS_ProcessPendingEvents_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:200
12 	xul.dll 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:250
13 	xul.dll 	nsSocketTransportService::Run 	netwerk/base/src/nsSocketTransportService2.cpp:594
14 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
15 	xul.dll 	nsThreadStartupEvent::Run 	xpcom/threads/nsThread.cpp:207
16 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
17 	ntdll.dll 	_SEH_epilog 	
18 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
19 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
20 	ntdll.dll 	_SEH_epilog 	
21 	mozcrt19.dll 	__dllonexit 	obj-firefox/memory/jemalloc/crtsrc/onexit.c:276
22 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
23 	kernel32.dll 	GetCodePageFileInfo 	

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=baa5ae44f0ba&tochange=0ff6d5984287

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsHttpPipeline%3A%3AGetConnectionInfo%28nsHttpConnectionInfo**%29
blocking2.0: --- → ?
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616591
Status: RESOLVED → VERIFIED
blocking2.0: ? → beta8+
Crash Signature: [@ nsHttpPipeline::GetConnectionInfo(nsHttpConnectionInfo**) ]
You need to log in before you can comment on or make changes to this bug.