The default bug view has changed. See this FAQ.

Embedding Apps can't do basic auth repeatedly, due to cache [squid proxy]

VERIFIED WORKSFORME

Status

()

Core
Embedding: APIs
P3
normal
VERIFIED WORKSFORME
17 years ago
3 years ago

People

(Reporter: edburns, Assigned: Darin Fisher)

Tracking

Trunk
mozilla0.9.2
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cache])

(Reporter)

Description

17 years ago
Hello,

My embedding app implements nsIPrompt to allow the user to provide username
and password data on a URL fetch.

If your disk cache is clear, and you visit a url with basic auth, it works 
fine.  However, if, at a later session, you visit the same URL, it will not 
work.  Disabling the cache prevents this problem.


Please re-assign to the cache person.

Updated

17 years ago
Assignee: valeski → gordon

Comment 1

17 years ago
-> g
(Reporter)

Comment 2

17 years ago
*** Bug 59981 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

17 years ago
Blocks: 59866
(Reporter)

Comment 3

17 years ago
Here's the pref to disable the cache:

user_pref("browser.cache.disk_cache_size", 0);
(Reporter)

Updated

17 years ago
Blocks: 60304

Updated

16 years ago
QA Contact: jrgm → mdunn

Comment 4

16 years ago
Updating QA Contact

Updated

16 years ago
Blocks: 64833, 70229

Comment 5

16 years ago
This bug seems pretty major, and blocks bug #60304 which is also pretty major. 
Any chance of getting this escalated -- or at least set to a specific milestone?

Updated

16 years ago
Target Milestone: --- → mozilla0.9.1

Comment 6

16 years ago
Correction: Changing QA contact for the Embed API bugs to David Epstein.
QA Contact: mdunn → depstein

Comment 7

16 years ago
Ed, is this still a problem with the lastest builds.  We have a new cache and 
we've cleaned up the HTTP validation code quite a bit.
Whiteboard: [cache]

Updated

16 years ago
Keywords: qawanted
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Comment 8

16 years ago
It doesn't authenticate at all to me. When I use the TestGtkEmbed and the
authentication dialog appears I can fill in any name/password value (even the
correct one) but the authenticated page never appears only the dialog reappears
again and again. Only the Cancel button works fine -> the authentication error
page appears.
(Assignee)

Comment 9

16 years ago
basic auth works just fine for me using TestGtkEmbed.  can you please supply
a testcase for this bug?  thx!

Comment 10

16 years ago
You can try this URL:

http://poli.feld.cvut.cz/~mraz/tmp/

User: josef Password: nechvil

I'm using a squid proxy to connect to Internet (I have no other possibility).

I've retested it with my own trunk build from 2001-06-12 and it still doesn't work.
(Assignee)

Comment 11

16 years ago
OK.. using a Netscape Proxy, I'm not having any trouble authenticating with the
testcase you provided.  Time to try squid.
(Assignee)

Comment 12

16 years ago
-> me
Assignee: gordon → darin
(Assignee)

Comment 13

16 years ago
OK.. once i setup a squid proxy i was able to duplicate this bug.
investigating...
(Assignee)

Comment 14

16 years ago
oops... i take that back... it seems to work just fine for me.
i previously mistyped the password :P

so, i'm not sure how to reproduce this bug.

Tom: could you get a packet trace?  (using a tool like ngrep --
http://ngrep.sourceforge.net), and if you have a debug build could you try
getting a HTTP log by setting the NSPR_LOG_MODULES=nsHttp:5 and NSPR_LOG_FILE=log
environment variables?  if you could generate either of these it would greatly
help in tracking down the cause of this problem.  thanks!
Summary: Embedding Apps can't do basic auth repeatedly, due to cache → Embedding Apps can't do basic auth repeatedly, due to cache [squid proxy]

Comment 15

16 years ago
So I've made more tests and it seems that with the M0.9.1 it doesn't work at all 
no matter when using/not using proxy. But I've made fresh trunk checkout and
recompiled it and it is FIXED now! So it could be probably resolved as WFM.
(Assignee)

Comment 16

16 years ago
marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
No longer blocks: 64833

Comment 17

16 years ago
was able to authenticate w/ above case.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 60304
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.