Closed Bug 616714 Opened 9 years ago Closed 9 years ago

Bug 603367 breaks non-libxul builds

Categories

(Firefox Build System :: General, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED
mozilla2.0b8

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

(Keywords: regression)

Attachments

(1 file)

In this revision:

http://hg.mozilla.org/mozilla-central/rev/3bb7e1a3cb22

USE_ANGLE is set in content/canvas/src/Makefile.in, which triggers http://hg.mozilla.org/mozilla-central/file/3bb7e1a3cb22/content/canvas/src/Makefile.in#l93, which is not needed, because layout/build/Makefile.in takes care of it.  Currently, non-libxul builds are broken because of it.
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #495262 - Flags: review?(khuey)
http://hg.mozilla.org/mozilla-central/rev/445e8a8d79b2
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
We're in the endgame of Firefox 4, and it's really important that we only work on blockers.  Maybe this should have been a blocker?  If not, let's make sure we stay focused on blocking bugs!
Not being able to build Firefox probably impedes fixing those blockers ;-)
(In reply to comment #3)
> We're in the endgame of Firefox 4, and it's really important that we only work
> on blockers.  Maybe this should have been a blocker?  If not, let's make sure
> we stay focused on blocking bugs!

Totally agreed.  This particular case was basically preventing me and the rest of the developers who build Firefox with libxul disabled from working on anything though.  :-)
I think there's a class of bugs like this that perhaps ostensibly should be blocking, since they're blocking developers from getting useful work done, but can be fixed so quickly (4 hours from filing to landing the fix) that the blocker nomination process is just too heavyweight. I don't think it makes sense to spend much time worrying about them either way, given how simple they are.
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.