HTTP authentication dialog should be tab-modal

RESOLVED DUPLICATE of bug 613785

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 613785
7 years ago
4 years ago

People

(Reporter: Roman, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0E)

The HTTP authentication dialog is currently window-modal. While it is shown, the user is unable to use any other tabs. Additionally, if the tab wishing to display the prompt is a background tab, it steals focus.

The desired behaviour is for the prompt to only block the tab it relates to, and not steal focus when it's shown.

Reproducible: Always

Steps to Reproduce:
1. Ctrl-click the specified URL to open it in a background tab.
2. Observe both the focus stealing and the modality.
(Reporter)

Updated

7 years ago
Blocks: 616843

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 613785

Updated

7 years ago
Blocks: 59314

Updated

7 years ago
No longer blocks: 59314

Comment 2

7 years ago
This issue has not been resolved in Firefox 4 Beta 12. HTTP Auth Dialogs (using the link above) still appear as a Window-Modal popup, not a Tab-Modal popup like expected.

Comment 3

6 years ago
This issue has not been resolved in Firefox 8.0 release. HTTP Auth Dialogs (using the link above) still appear as a Window-Modal popup, not a Tab-Modal like expected.

Comment 4

6 years ago
Opera, Google Chrome, Maxthon - don't block all tabs then one tab need http password entrty. Even Internet Explorer 8.0 don't block, until you activate tab, wich wait password entry and flashing by tab title.
You need to log in before you can comment on or make changes to this bug.