Last Comment Bug 616918 - Turn on ANGLE on Win64
: Turn on ANGLE on Win64
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: Trunk
: x86_64 Windows Vista
: -- normal with 2 votes (vote)
: ---
Assigned To: Makoto Kato [:m_kato]
:
Mentors:
Depends on:
Blocks: tracking_win64 671567
  Show dependency treegraph
 
Reported: 2010-12-05 21:07 PST by Makoto Kato [:m_kato]
Modified: 2011-08-12 06:57 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1 (35.28 KB, patch)
2010-12-05 21:07 PST, Makoto Kato [:m_kato]
no flags Details | Diff | Splinter Review
fix v2 (21.50 KB, patch)
2011-06-08 03:03 PDT, Makoto Kato [:m_kato]
jacob.benoit.1: review+
Details | Diff | Splinter Review
fix v3 (24.36 KB, patch)
2011-08-04 01:27 PDT, Makoto Kato [:m_kato]
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] 2010-12-05 21:07:17 PST
Created attachment 495441 [details] [diff] [review]
fix v1

http://code.google.com/p/angleproject/issues/detail?id=55 and some fixes
Comment 1 Vladimir Vukicevic [:vlad] [:vladv] 2010-12-27 12:15:03 PST
*** Bug 621007 has been marked as a duplicate of this bug. ***
Comment 2 Jason Ng 2010-12-27 14:33:24 PST
Currently:     
      
        
Adapter Description: NVIDIA GeForce 9500GS
Vendor ID: 10de
Device ID: 0644
Adapter RAM: 512
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version:8.17.12.6099
Driver Date: 10-16-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 1/1 Direct3D 10
Comment 3 Makoto Kato [:m_kato] 2011-06-08 03:03:09 PDT
Created attachment 537974 [details] [diff] [review]
fix v2
Comment 4 Benoit Jacob [:bjacob] (mostly away) 2011-06-08 05:12:05 PDT
Comment on attachment 537974 [details] [diff] [review]
fix v2

r=me with the following reservation:

+ifeq ($(OS_TEST),x86_64)
+DXLIB_ARCH=x64
+else
+DXLIB_ARCH=x86
+endif

We're not interested about whether the _OS_ is 64bit, but rather about whether the application is. What does OS_TEST really mean? If it really means the OS then it's not what you want here.

Since this requires changes inside of ANGLE itself, could you please get this part of your patch reviewed upstream?
http://code.google.com/p/angleproject/issues/list
They'll  be more competent than me to review changes in ANGLE itself.
Comment 5 Makoto Kato [:m_kato] 2011-06-15 23:54:32 PDT
(In reply to comment #4)
> Since this requires changes inside of ANGLE itself, could you please get
> this part of your patch reviewed upstream?
> http://code.google.com/p/angleproject/issues/list
> They'll  be more competent than me to review changes in ANGLE itself.

Although I already filed as Issue 55 (http://code.google.com/p/angleproject/issues/detail?id=55), it is no answer about reviewing.

Benoit, Do you know a review process of ANGLE?  (Via Gerrit?)  I cannot found a document for it.
Comment 6 Benoit Jacob [:bjacob] (mostly away) 2011-06-16 04:48:02 PDT
I don't know anything else than attaching patches and pinging them. Try emailing Nicolas and Daniel; also I'm CCing Daniel here.
Comment 7 daniel-bzmz 2011-06-16 05:37:46 PDT
I didn't realize this was a blocker for you.  Can you make sure the patches on Issue 55 are up to date for current top-of-tree, and detail what sort of testing has been done with the 64-bit build?
Comment 8 Benoit Jacob [:bjacob] (mostly away) 2011-06-16 06:35:34 PDT
(In reply to comment #4)
> Comment on attachment 537974 [details] [diff] [review] [review]
> fix v2
> 
> r=me with the following reservation:
> 
> +ifeq ($(OS_TEST),x86_64)
> +DXLIB_ARCH=x64
> +else
> +DXLIB_ARCH=x86
> +endif

Oh, I just remembered that we already have a variable for this in our build system: MOZ_DIRECTX_SDK_CPU_SUFFIX
Comment 9 daniel-bzmz 2011-06-21 07:47:15 PDT
Updated patches from Issue #55 have been checked in (ANGLE r698)
Comment 10 Benoit Jacob [:bjacob] (mostly away) 2011-06-21 08:08:15 PDT
Thanks a lot.
Comment 11 Makoto Kato [:m_kato] 2011-07-27 21:51:17 PDT
I need 1 more fix to pass mochitest-1.  I filed as issue 190.
Comment 12 Makoto Kato [:m_kato] 2011-07-27 21:53:07 PDT
Daniel, could you review http://code.google.com/p/angleproject/issues/detail?id=190 ?  A patch is attached into that bug.
Comment 13 daniel-bzmz 2011-07-29 10:01:37 PDT
checked in as ANGLE r707
Comment 14 Benoit Jacob [:bjacob] (mostly away) 2011-07-29 12:15:46 PDT
Thanks for the heads up. Will sync our ANGLE copy soon.
Comment 15 Makoto Kato [:m_kato] 2011-08-04 01:27:46 PDT
Created attachment 550620 [details] [diff] [review]
fix v3
Comment 16 Benoit Jacob [:bjacob] (mostly away) 2011-08-10 12:20:10 PDT
Comment on attachment 550620 [details] [diff] [review]
fix v3

Excellent! Thanks for keeping our ANGLE patchset clean too.
Comment 18 Mounir Lamouri (:mounir) 2011-08-12 06:57:06 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/8628c51e497c

Note You need to log in before you can comment on or make changes to this bug.