Closed Bug 617007 Opened 9 years ago Closed 9 years ago

Helvetica Font Style Rendering Change with OS 10.6.5 Update

Categories

(Core :: Layout: Text and Fonts, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 611855

People

(Reporter: aguyawry, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_5; en-US) AppleWebKit/534.7 (KHTML, like Gecko) Chrome/7.0.517.44 Safari/534.7
Build Identifier: 3.6.12

After a Mac OS X update from 10.6.4 to 10.6.5, I noticed Helvetica fonts rendering differently with the same CSS style applied. See the Reproduction instructions below. Previous to the OS 10.6.5 update, the example code would render a font without an italic style. After the update the font is rendered with an italic style.

Reproducible: Always

Steps to Reproduce:
Create a html test page with the code below. Have it render on machines with 10.6.4 and 10.6.5.


<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">

<html lang="en">
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
    <title>Font Test</title>
    
    <style type="text/css">
    body{
        font-family:Helvetica;
        font-size:62.5%;
    }
    h1, p{ 
        font-size:1.6em;
        font-weight:200;
    }
    </style>
</head>
<body>


<h1>This is a font test!</h1>
<p>This is a font test!</p>

</body>
</html>
Actual Results:  
10.6.4 page renders in a non-italic font for both tags. 10.6.5 page renders in italic font.

Expected Results:  
I would expect the 10.6.5 version to render in a non-italic font.

- I have tried this on multiple systems (pre and post 10.6.5) and checked that the fonts are not corrupt.
- Font weights up to 300 seem to have this issue.
- Font size does not seem to matter.
- Other browsers on the same system do not seem to render in italic. Only notice this in Firefox.
- Only the Helvetica font seems effected.
Testcase from comment 0 attached for convenience.

Does this occur using a clean profile ( http://support.mozilla.com/en-US/kb/Managing%20profiles ) and also when using safe mode ( http://support.mozilla.com/en-US/kb/Safe%20Mode )?
This is caused by an OS X bug introduced in the 10.6.5 update (see bug 611855, comment 10), but we have added a workaround, so this should be fixed in 3.6.13 and current trunk builds.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 611855
Awesome. Sorry for the dupe. Guess my search criteria when looking for this existing problem wasn't that great. Thank you for your help.
You need to log in before you can comment on or make changes to this bug.