Closed Bug 617210 Opened 9 years ago Closed 6 years ago

Increase mobile batch size

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
Future

People

(Reporter: rnewman, Assigned: nigelb)

References

Details

Attachments

(1 file)

The batch size is currently 50, with a note that it's limited because of URL
length restrictions. GUIDs can be up to 64 chars long.

Philipp's bookmark GUID work will drop that to 12 chars, which should allow us
to go north of 200.

For mconnor's 17,000 history items, that would drop us from 340 GETs to 85: a
far more pleasing number. (Adding a cap of 5,000 records would put the max
number of fetches at 25, of course.)

mconnor: "let's actually leave the batch size until after b8".

See Bug 616265.
Grabbing this one :)
Assignee: nobody → nigelbabu
Status: NEW → ASSIGNED
Attached patch patch-v1Splinter Review
Patch from what I understood the fix to be.
Attachment #636452 - Flags: feedback?(rnewman)
This bug might be misnamed.

The constant that's now eligible to change after our GUIDs got shorter is DEFAULT_MOBILE_GUID_FETCH_BATCH_SIZE... and also DEFAULT_GUID_FETCH_BATCH_SIZE.

So:

* Verify that all of our GUIDs are 12 chars. If so, change the desktop constant to 200.
* If it's only some engines (bookmarks and history, say), do as the comment says and override the behavior in those engines.

Separately, MOBILE_BATCH_SIZE limits how many records we fetch and process in a normal Sync fetch on mobile, presumably for memory reasons. It doesn't make sense for the GUID fetch batch size to be larger than this value.

So, either:

* Bump both DEFAULT_MOBILE_GUID_FETCH_BATCH_SIZE and MOBILE_BATCH_SIZE to a number between 50 and 200, or
* Leave these two constants alone, so that we only fetch more on desktop.
Duplicate of this bug: 631133
Comment on attachment 636452 [details] [diff] [review]
patch-v1

I think this code is dead, so wontfixing this. Thanks anyway, Nigel!
Attachment #636452 - Flags: feedback?(rnewman)
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.