please provide a way to clone/copy (append) a product's settings

RESOLVED DUPLICATE of bug 209195

Status

()

RESOLVED DUPLICATE of bug 209195
8 years ago
8 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
every time i need to move a component to a new product, i have to:
1. correctly set group access controls (i generally remember this) - based on the old product
2. correctly set voting (i sometimes forget this) - based on the old product
3. create all the versions and target milestones - based on the old product
4. edit each flagtype and add it to the new product - if it was present in the old product

step 4 is where i think i've nearly always messed up. it's also by far the hardest since flagtypes have the *worst* interface imaginable for doing anything. you can't predict which flagtypes apply to a product and even if you load an individual flagtype, it isn't simple due to globals/inclusion/exclusion/and support for per component.

for the major move at whistler we had a script which basically did these things (including flagtypes iirc).

there should be a <select> where the admin can choose which items to copy (default with all selected):
<option>GAC
<option>Versions
<option>Milestones
<option>Flags
<option>Votes

there should probably be a merge option [source wins, dest wins, favor source, favor dest, auto], but i'm not asking for one right now, what follows is 'auto'.

for GAC, each entry in source needs to be added to dest, if there are conflicts the most relaxed version should probably win, that means that Shown beats NA and Shown beats Mandatory. Each conflict should be reported so that the admin knows what was changed and can decide if it's correct.

for versions/milestones, each entry in source needs to be added to dest, conflicts between sortkeys and visible states should be source wins on sortkeys and most effort wins on visible states (since it takes effort to uncheck an item in visible states, the unchecked state should win).

for flags, any flagtype which includes source should have an addition of include dest, any flagtype which has an exclude of source should have an addition of exclude dest. If there's a component in source which has an include for the flagtype and there is no matching component in dest then an include for dest should be added.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 209195
You need to log in before you can comment on or make changes to this bug.