Last Comment Bug 617296 - A map is not displayed on map.yahoo.co.jp
: A map is not displayed on map.yahoo.co.jp
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 All
: P1 normal (vote)
: mozilla2.0b8
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
:
Mentors:
http://map.yahoo.co.jp/pl?lat=34.7057...
: 617892 (view as bug list)
Depends on:
Blocks: 609030
  Show dependency treegraph
 
Reported: 2010-12-07 04:16 PST by Alice0775 White
Modified: 2010-12-22 19:40 PST (History)
5 users (show)
bzbarsky: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Proposed fix (3.11 KB, patch)
2010-12-07 07:39 PST, Boris Zbarsky [:bz] (still a bit busy)
jonas: review+
jonas: approval2.0+
Details | Diff | Splinter Review

Description Alice0775 White 2010-12-07 04:16:31 PST
Build Identifier: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101206 Firefox/4.0b8pre ID:20101206030318

A map is not displayed on map.yahoo.co.jp


Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Open URL ( http://map.yahoo.co.jp/pl?lat=34.70577580&lon=135.51119390&ac=27127&az=2.1&v=2&sc=3 )
3.

Actual Results:
*A map is not displayed

 
 Error: URL is not a constructor
 Source file: http://map.yahoo.co.jp/js/scroll.js?_t=1137778669
 Line: 11

*Error when click "検索" tab (below Yahoo! logo)
 Error: $m is not defined
 Source file: javascript:$m.changeTab('search');
 Line: 1

*Error when click "検索" button at the right side of input box
 Error: $m is not defined
 Source file: http://map.yahoo.co.jp/js/scroll.js?_t=1137778669
 Line: 135

Expected Results:
 A map should be displayed.

Regression window;
Works:
http://hg.mozilla.org/mozilla-central/rev/5c0802167d09
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101122 Firefox/4.0b8pre ID:20101123001318
Fails:
http://hg.mozilla.org/mozilla-central/rev/4b9ba5049e66
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101123 Firefox/4.0b8pre ID:20101123045657
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5c0802167d09&tochange=4b9ba5049e66

The following changeset causes the problem
bd5273da5263	Jonas Sicking — Bug 609030: Update createBlobURL/revokeBlobURL to it's final name. r=jst a=blocker
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2010-12-07 06:32:18 PST
It looks like the site uses |new URL(this)| in that first script above.  This used to work, though I can't find where they define a |function URL|.  But now window.URL is a (non-replaceable?) global property, so this fails.
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2010-12-07 06:37:04 PST
Though no, that doesn't make sense.  If I do:

  function URL() {}

at global scope then new URL() works.  So we really need to figure out where the site expects this URL constructor to come from.
Comment 3 Alice0775 White 2010-12-07 06:57:18 PST
It is defined in 	http://map.yahoo.co.jp/js/scroll.js line 78
var URL=YMap.URL=function(a){this.ymain=a;this.initialize();};
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2010-12-07 07:05:19 PST
Aha, an assignment.  Yeah, the non-replaceability is the problem there.
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2010-12-07 07:39:12 PST
Created attachment 495826 [details] [diff] [review]
Proposed fix

Jonas, we probably need to get the spec updated to say that this property is replaceable, right?
Comment 6 Jonas Sicking (:sicking) No longer reading bugmail consistently 2010-12-07 13:14:27 PST
Comment on attachment 495826 [details] [diff] [review]
Proposed fix

There is no actual spec for the URL object yet, but I'll tell Adam Barth, who is the expected editor, that this is needed.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2010-12-08 10:47:15 PST
Pushed http://hg.mozilla.org/mozilla-central/rev/35ea831c27ab

I still need to write a test for this; I forgot to do that earlier...
Comment 8 Alice0775 White 2010-12-09 02:59:03 PST
*** Bug 617892 has been marked as a duplicate of this bug. ***
Comment 9 Boris Zbarsky [:bz] (still a bit busy) 2010-12-22 19:40:44 PST
And pushed a test as http://hg.mozilla.org/mozilla-central/rev/5f8c179e1725

Note You need to log in before you can comment on or make changes to this bug.