Closed Bug 617320 Opened 10 years ago Closed 10 years ago

Failures in test_service_sync_updateEnabledEngines.js

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: philikon, Assigned: rnewman)

References

Details

Attachments

(1 file)

I can reproduce this failure locally on OSX after re-enabling that test.
Summary: Failures + hangs in test_service_sync_updateEnabledEngines.js → Failures in test_service_sync_updateEnabledEngines.js
Status: NEW → ASSIGNED
Attached patch Fix tests.Splinter Review
When we decided not to augment the test suite for the belt-and-braces engine fix, I reverted the test file... which (a) removed my test fixes, as well as the new test I was adding, and (b) removed my force-enable of the test.

Of course the test suite then passed, because the tests were disabled.

This patch corrects the test.
Attachment #495847 - Flags: review?(philipp)
Comment on attachment 495847 [details] [diff] [review]
Fix tests.

Really... we'll have to write a crossweave test for this.  File a bug on that?
Attachment #495847 - Flags: review?(philipp) → review+
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.