Crash when trying to load session from another Mac

VERIFIED DUPLICATE of bug 602333

Status

()

--
critical
VERIFIED DUPLICATE of bug 602333
8 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

I am trying to load another session that I saved on another Mac running Firefox Beta 4 build 7 into the current beta 4 build 7 on this Mac and it crashes after a minute or two with this error: (have removed personal info from this and replaced by ...

12/7/10 11:54:14 AM	[0x0-0x4fd4fd].org.mozilla.firefox	!!! [Hook] hook(http://www.youtube.com/watch?v=IT2YTURFEWc&feature=related): [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///...(my home directory).../Library/Application%20Support/Firefox/Profiles/o4q5fkk7.default/extensions/%7Bb9db16a4-6edc-47ec-a1f4-b86292ed211d%7D/components/dhDOMHook.js :: anonymous :: line 130"  data: no]

I have disabled Flash in the Plug-ins so not sure if this message has to do with the crash or with the fact that Flash is disabled.

But every time I've tried to restore this saved session from the other Mac, Firefox has crashed after about a minute or two.

At first, I had tried to merge the session from the other Mac with the current session and it also crashed after a while and also it would create another set of windows (two more in this case) that were duplicates of the already existing windows, not the windows/tabs from the other Mac session, but it still crashes.

So tried to just load the other session without merging and Firefox still crashes. 

The other Mac is running MAC OS X 10.5.8 and the crashing Mac is running Mac OS X 10.6.5 if that matters, but both are running Beta 4 build 7 and the other Mac has not crashed with the session I'm trying to load.

I'm not sure what else to try.

-Bob


Reproducible: Always

Steps to Reproduce:
1. load session from other Mac that I copied over to this Mac
2. wait a little while and it crashes - every thing appears to be happening as
expected up until the crash - by that I mean other URL's are loaded, the screens look correct with the correct app tabs and groups and then it crashes with the above error. One odd thing is that when the crash window apperas the URL listed under "Details" is not the youtube site but a site on apple.com (can't recall exact site and its now gone after the restart). I will try and do the load session again after I save/create this bug so I don't loose all this effort...
Actual Results:  
Firefox crashes

Expected Results:  
Open other session (two windows and 91 tabs and about 7-8 groups)
(Reporter)

Comment 1

8 years ago
Well - tried to load the session again and it crashes, so copied the details and the URL in it is a completely different site. The details are:

AdapterRendererIDs: 0x22400,0x22400,0x20400
Add-ons: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}:20100908,{b9db16a4-6edc-47ec-a1f4-b86292ed211d}:4.8.1,testpilot@labs.mozilla.com:1.0.3,{EF522540-89F5-46b9-B6FE-1829E2B572C6}:4.9.4,{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:1.3.1,{1280606b-2510-4fe0-97ef-9b5a22eafe30}:0.6.9.3,status4evar@caligonstudios.com:2010.11.20.19,{ada4b710-8346-4b82-8199-5de2b400a6ae}:1.9.9.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:4.0b7
BuildID: 20101104131842
CrashTime: 1291752601
EMCheckCompatibility: true
Email: my-email-address-was-here-and-i-removed-it
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1290122175
Notes: Renderers: 0x22400,0x22400,0x20400
ProductName: Firefox
ReleaseChannel: beta
SecondsSinceLastCrash: 4392
StartupTime: 1291748941
Theme: classic/1.0
Throttleable: 1
URL: http://www.crossmyt.com/hc/gen/deerfild.html#n12
Vendor: Mozilla
Version: 4.0b7

This report also contains technical information about the state of the application when it crashed.

I will try and copy this same session back to the original mac and do a sum and diff on the two versions of the file and see if there is anything different. Will then try and load the session back on the same Mac that created it and see what happens...have to save this and add more after comparing...
(In reply to comment #0)
> 12/7/10 11:54:14 AM    [0x0-0x4fd4fd].org.mozilla.firefox    !!! [Hook]
> hook(http://www.youtube.com/watch?v=IT2YTURFEWc&feature=related): [Exception...
> "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE)
> [nsIDOMHTMLDocument.createElementNS]"  nsresult: "0x80040111
> (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: file:///...(my home
> directory).../Library/Application%20Support/Firefox/Profiles/o4q5fkk7.default/extensions/%7Bb9db16a4-6edc-47ec-a1f4-b86292ed211d%7D/components/dhDOMHook.js
> :: anonymous :: line 130"  data: no]

This is coming from an extension you have installed. Perhaps compatibility has been forced or the extensions is claiming it's compatible when it's not. Or it's genuinely just a bug in the extension.

It looks like that extension is Video DownloadHelper (https://addons.mozilla.org/en-US/firefox/addon/3006/). You can try contacting them or just disable the extension.

Please let me know if disabling the extension fixes the issue so it can be confirmed it's not a problem with Firefox. Thanks.
(Reporter)

Comment 3

8 years ago
It still crashes - but do not get that error in syslog - now only thing that happens is I get a "Exited with error code 1" from Firefox. Here is the "Details" from the Mozilla Crash Reporter window:


==========================Details FOllow=================================
AdapterRendererIDs: 0x22400,0x22400,0x20400
Add-ons: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}:20100908,testpilot@labs.mozilla.com:1.0.3,{EF522540-89F5-46b9-B6FE-1829E2B572C6}:4.9.4,{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:1.3.1,{1280606b-2510-4fe0-97ef-9b5a22eafe30}:0.6.9.3,status4evar@caligonstudios.com:2010.11.20.19,{ada4b710-8346-4b82-8199-5de2b400a6ae}:1.9.9.1,{972ce4c6-7e08-4474-a285-3208198ce6fd}:4.0b7
BuildID: 20101104131842
Comments: Another crash 
CrashTime: 1291757463
EMCheckCompatibility: true
Email: my-email-address-was-here
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1290122175
Notes: Renderers: 0x22400,0x22400,0x20400
ProductName: Firefox
ReleaseChannel: beta
SecondsSinceLastCrash: 405
StartupTime: 1291757353
Theme: classic/1.0
Throttleable: 1
URL: http://support.apple.com/downloads#10.5.8
Vendor: Mozilla
Version: 4.0b7

This report also contains technical information about the state of the application when it crashed.
=======================End_of_Details======================================

I also tried to reload that exact same session onto original 10.5.8 system and it does not crash whether I have the Download Helper extension enabled or not.

So would appear to be specific to Mac OS X 10.6 (I have 10.6.5) and I looked in the ~/Library/Logs/CrashReporter folder and there are no logs to go along with these crashes for Firefox - so the only hint is the single message in syslog that says:

12/7/10 2:31:04 PM	com.apple.launchd.peruser.501[326]	([0x0-0x553553].org.mozilla.firefox[34231]) Exited with exit code: 1

-Bob

ps - how did you make the connection to the "Download Helper" extension/add-on?? Just curious how you picked that one??? THanks for the help
(Reporter)

Comment 4

8 years ago
Just a bit more detail - have two windows and 91 tabs in this session that has problems. I can't really send this session file as it contains information that will give secure info (cookies, etc). But I suppose I could extract a list of just the URL's if that would be helpful - let me know. Thanks again for the help.

-Bob
It might be a different extension then. I would try disabling all extensions (or just go straight to using Safe Mode - http://support.mozilla.com/en-US/kb/Safe%20Mode).

After you disable them all, you can re-enable one-by-one and figure out which is the one causing issues.

Also, if you could link to the crash report that gets submitted, that would be very helpful for identifying the issue. You can find the list of recent crash reports by navigating to about:crashes after starting up.

(In reply to comment #3)
> ps - how did you make the connection to the "Download Helper"
> extension/add-on?? Just curious how you picked that one??? THanks for the help

Each extension has a unique identifier, often a UUID. A folder is created for each in your extensions directory. The error you reported was coming from an extension identifying as {b9db16a4-6edc-47ec-a1f4-b86292ed211d}, which after a little bit of searching is Video DownloadHelper.
(Reporter)

Comment 6

8 years ago
Here are the submitted crash reports from today. The last few didn't have the "Download Helper" enabled, but since it didn't make a difference in Firefox crashing, but just in the message that appeared in the syslog, not sure it makes any difference.

Before I actually post the Report ID numbers - is there any personal information that is in any of these reports (my e-mail, etc)??

Thanks - just want to be sure of what's going to be revealed once I post these report id's and what anyone with Bugzilla searching might find.

Thanks again for your help...am going to try disabling all extensions like you suggest and then try the session again...

-Bob
(Reporter)

Comment 7

8 years ago
Well, I disabled all extensions and add-ons except for "Session Manager" and now there is no Firefox crash when loading the session file that was crashing before.

It's been several minutes since I loaded this session that was always causing crashes after about 30-60 seconds when all the extensions and add-ons were turned on (actually a couple of them were turned off already).

So looks like you're right about one of the extension or add-ons that are causing the problem. I will now try enabling them in groups to narrow down which one it REALLY is.

Thanks again for your help...

-Bob
(Reporter)

Comment 8

8 years ago
Well, after several iterations of turning things off and then loading the session that causes a crash, its come down to the only extension or plug-in turned on is the Session Manager itself. I turned off all plug-ins and all extensions except "Session Manager" and it is the most up-to-date version (version is 0.6.9.3). And the bug is specific to Mac OS X 10.6.5 as I run fine with same setup on Mac OS X 10.5.8 on a MacBook (problem system is a MacPro desktop system). The last crash was report id was bp-b7a2e268-6c30-4e5f-92bf-9ef492101208

Let me know if you would anything more.

-Bob
(Reporter)

Comment 9

8 years ago
One thing that just occurred to me - could this be a case-sensitive related bug? The system that Firefox keeps crashing on has a boot volume (where Firefox is currently running from) that is formatted as a case-sensitive HFS+ filesystem.

Just an idea...

The weirdest thing of all is that there is no entry about the crash in the system log files that I can find (not now anyway that I've removed all the extensions and plug-ins except for Session Manager...I will continue to monitor the situation looking for any more clues...

Should I contact the Session Manager developer??


-Bob
(Reporter)

Comment 10

8 years ago
And just to make clear - the problem only occurs with certain sessions that I try to load on a 10.6.5 MacPro system that were created on another Mac OS X 10.5.8 MacBook system. Whenever I use sessions created on the same computer (this OS X 10.6.5 system) everything works fine as far as I know.
Ah that crash points to a problem in the javascript engine (bug 602333). Looks like it might have only been causing issues on x64 systems (which would explain your 10.6 vs 10.5 case).

Did you still crash if you disabled Session Manager?

So there are 2 things I'd like to see tried.
1. Do you still crash if you disable MethodJIT (set the javascript.options.methodjit.content pref to false, restart with crashy session). Make sure you reset this pref to true after testing!
2. Try a nightly (http://nightly.mozilla.org) and see if it still crashes (again, make sure the pref is true!)
(Reporter)

Comment 12

8 years ago
Tried both of your suggestions and they both work - tried option 1 (turning javascript.options.methodjit.content to false and ran for about 1.5 hours with no problem) and as soon as I turned it back to true crashed in about 2 minutes.

What exactly does setting this methodjit option to false really end up doing???

Downloaded Minefield 4.0b8 and hasn't crashed in about 20 minutes - far longer than before with 4.0b7 and in fact am using it right now.

So both choices seem to have stopped the crashing for this session manager problem.

Do you want more testing??? Does this put an end to this issue (ie, the problem is fixed in the next version), or does the problem need to be narrowed down to identify what the problem really is???
(Reporter)

Comment 13

8 years ago
Also about your question about trying to disable session manager - this is not doable as that is the reason I'm doing all this, ie trying to use the session manager. Is there another way to load a session without the session manager? If so I will try, but need to know how.

Let me know...

-Bob
(In reply to comment #12)
> Tried both of your suggestions and they both work - tried option 1 (turning
> javascript.options.methodjit.content to false and ran for about 1.5 hours with
> no problem) and as soon as I turned it back to true crashed in about 2 minutes.

Great. That confirms that theory.

> What exactly does setting this methodjit option to false really end up doing???

Turns off an optimization of the JavaScript engine, which is what was causing your crash.

> Do you want more testing??? Does this put an end to this issue (ie, the problem
> is fixed in the next version), or does the problem need to be narrowed down to
> identify what the problem really is???

Nope, it sounds like all is well and you've confirmed that the fix works :)

(In reply to comment #13)
> Also about your question about trying to disable session manager - this is not
> doable as that is the reason I'm doing all this, ie trying to use the session
> manager. Is there another way to load a session without the session manager? If
> so I will try, but need to know how.

At this point it doesn't seem necessary. Firefox has a built in session restore that lets you restore your previous session. Session Manager adds some features (like being able to save & restore specific sessions, not just the previous one).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 602333
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.