Closed Bug 617437 Opened 12 years ago Closed 12 years ago

Sync randomly moved dozens of bookmarks out of folders into the Unsorted Bookmarks folder

Categories

(Firefox :: Sync, defect)

x86
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED

People

(Reporter: steffen.wilberg, Unassigned)

References

Details

Attachments

(2 files)

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101207 Firefox/4.0b8pre

I have my bookmarks sorted into folders and sub-folders below the Bookmarks Menu "folder".

Today, Sync randomly moved dozens of bookmarks out of folders into the Unsorted Bookmarks folder. Some folders were not affected, but others were completely emptied, leaving empty folders behind, others were only partly raided.

From the log:
2010-12-07 19:13:44	Service.Main         DEBUG	Weave Version: @weave_version@ Local Storage: 4 Remote Storage: 4

2010-12-07 19:13:45	Engine.Bookmarks     DEBUG	First sync, uploading all items
2010-12-07 19:13:46	Engine.Bookmarks     INFO	534 outgoing items pre-reconciliation

2010-12-07 19:13:55	Engine.Bookmarks     WARN	Error processing record: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIAnnotationService.setItemAnnotation] Stack trace: anno()@resource://services-sync/util.js:270 < resource://services-sync/engines/bookmarks.js:677 < BStore_changeItemID()@resource://services-sync/engines/bookmarks.js:678 < _handleDupe()@resource://services-sync/engines/bookmarks.js:248 < resource://services-sync/engines.js:201 < SyncEngine__reconcile()@resource://services-sync/engines.js:628 < resource://services-sync/engines.js:201 < resource://services-sync/engines.js:466 < innerBind()@resource://services-sync/util.js:1336 < resource://services-sync/base_records/collection.js:154 < Channel_onDataAvail()@resource://services-sync/resource.js:451
(22 times)

2010-12-07 19:13:59	Store.Bookmarks      DEBUG	Reparenting orphans 950,494,1295,1296 to 492
(12 times)

2010-12-07 19:27:54	Service.Main         INFO	Sync completed successfully in 850.79 secs.
Attached file sync log, part 1
There were also more than 200 entries like this:
2010-12-07 19:13:49	Store.Bookmarks      DEBUG	Changing GUID akSNP9vHK3xJ to -2thGvJjaexG
Attached file sync log, part 2
(In reply to comment #1)
> There were also more than 200 entries like this:
> 2010-12-07 19:13:49    Store.Bookmarks      DEBUG    Changing GUID akSNP9vHK3xJ
> to -2thGvJjaexG

That's expected as the bookmarks engine consolidates duplicates. The exception you're seeing isn't.
Flags: in-testsuite?
Ok, I've taken a closer look at this. First of all, Steffen, sorry we broke your bookmarks :/ Good news is that Sync makes backups of your bookmarks before syncing. You can restore by going to Bookmarks -> Show All Bookmarks and then clicking on the star icon in the window that opens.

Now for the actual problem: I can see some oddities with dupes, in other words, when two machines have the same set of bookmarks and Sync needs to reconcile. I have identified some problematic areas in the code and am addressing them.

I cannot reproduce the exception at all, though. Are you seeing oddities with a particular group of bookmarks or folders? If you want feel free to send me your bookmark backup file (the .json file the bookmark backup saves) via private email so I stand a better chance of reproducing. Though if you'd rather not that's ok.
This should be fixed now.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 621584
reporter, please verify this is fixed for you.
This didn't happen again, and I can't reproduce it because I failed to make a backup of the bookmarks backup file after it happened, so that backup is gone :(
Ok, thank you, Steffen.
Status: RESOLVED → VERIFIED
I am still having this problem. I've had hundreds of carefully organized business bookmarks scrambled during desktop PC syncs with my laptop pc, android phone, and ipad. It happens every time I add a new device.
See bug #812348
This is a very old bug, addressing particular issues; let's keep your discussion in Bug 812348, marty.

Thanks!
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.