Flash plugin not visible in Google Reader

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: sylvain.pasche, Assigned: bas.schouten)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker], URL)

(Reporter)

Description

8 years ago
To reproduce, open Google Reader and subscribe to a feed that contains Flash videos (for instance http://googlecode.blogspot.com/). The Flash videos inside the feed are rendered as white. They still respond to mouse events.

It regressed between 20101110 and 20101111: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=df1d1ff6b489&tochange=0f17e5f1eb01

My guess would be bug 596451
This is WFM on WinXP with D3D9 only on Build http://hg.mozilla.org/mozilla-central/rev/b1b57869cb43 => D3D10 resp. D2D + Plugin Issue?
(Reporter)

Comment 2

8 years ago
I can't reproduce in my XP vm but it happens in my Win7 vm or host.

I'm using Flash 10.1.102.64
Turning 'off' Hardware Accel allows the vids to show.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
(Reporter)

Comment 4

8 years ago
Works again with beta 9.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 5

8 years ago
... and the issue is back in beta 10.
Status: RESOLVED → REOPENED
blocking2.0: --- → ?
Resolution: WORKSFORME → ---
Bas, can you look into this? I'm going to say this blocks, but if you disagree, please say so.
Assignee: nobody → bas.schouten
blocking2.0: ? → final+
Whiteboard: [softblocker]

Comment 7

8 years ago
I cannot reproduce on nightlies with D3D10+D2D/Flash 10.1.102.64
(Assignee)

Comment 8

8 years ago
Can anyone confirm this doesn't reproduce on the latest nightlies?
(Reporter)

Comment 9

8 years ago
I can confirm it works again on beta 11 and latest nightly.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.