Values starting with a dot or an underscore are no longer hidden in reports

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Reporting/Charting
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

3.6.3
Bugzilla 3.6
Bug Flags:
approval +
approval4.0 +
approval3.6 +

Details

Attachments

(1 attachment)

769 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Created attachment 496224 [details] [diff] [review]
patch, v1

In bug 284650, we disabled the Private feature of hash keys starting with dots and underscores, so these characters are no longer a problem. And the current hack in report.cgi doesn't work, and makes things even worse as these values are not displayed at all. Removing this hack fixes the problem.
Attachment #496224 - Flags: review?(mkanat)

Updated

7 years ago
Attachment #496224 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval4.0+
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 1

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified report.cgi
Committed revision 7617.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified report.cgi
Committed revision 7493.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified report.cgi
Committed revision 7212.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.