5/10 build gets frequent but Random start-up crashes in raptorgfxwin.dll

VERIFIED DUPLICATE of bug 6934

Status

Core Graveyard
Tracking
P3
critical
VERIFIED DUPLICATE of bug 6934
19 years ago
a year ago

People

(Reporter: Paul MacQuiddy, Assigned: chris hofmann)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: top talkback problem -still seeing in 5/13 build, URL)

(Reporter)

Description

19 years ago
I am crashing on start-up around a third of the time in raptorgfxwin.dll using
may 10 builds on win95. A talkback report has been filed with tracking ID
EJK392FH.

This problem is not seen on mac/linux.
(Assignee)

Updated

19 years ago
Assignee: don → kipp
Summary: Random start-up crashes in raptorgfxwin.dll → 5/10 build gets frequent but Random start-up crashes in raptorgfxwin.dll
(Assignee)

Comment 1

19 years ago
Here is the stack from paulmac's crashes...
He seems to hit this at a pretty high rate on the 5/10 builds.
blee sees this too.

Nothing has changed in nsRenderingContextWin.cpp for awhile.
and we don't seem to be getting symbol infromation out of
RAPTORHTML.DLL.   Shiva/leaf, can you check check on the later?

Anyone have any ideas?
 Call Stack:    (Signature = nsRenderingContextWin::DrawImage 759483e4)
  nsRenderingContextWin::DrawImage
[d:\builds\seamonkey\mozilla\gfx\src\windows\nsRenderingContextWin.cpp, line
1659]
  RAPTORHTML.DLL + 0x77844
  (0x01707844)
  RAPTORHTML.DLL + 0x7765c
  (0x0170765c)
  RAPTORHTML.DLL + 0x76f36
  (0x01706f36)
  RAPTORHTML.DLL + 0x25d74
  (0x016b5d74)
  RAPTORHTML.DLL + 0x25c9a
  (0x016b5c9a)
  RAPTORHTML.DLL + 0x26556
  (0x016b6556)
  RAPTORHTML.DLL + 0x78ada
  (0x01708ada)
  RAPTORHTML.DLL + 0x25d74
  (0x016b5d74)
  RAPTORHTML.DLL + 0x25c9a
  (0x016b5c9a)
  RAPTORHTML.DLL + 0x26556
  (0x016b6556)
  RAPTORHTML.DLL + 0x78da9
  (0x01708da9)
  RAPTORHTML.DLL + 0x25d74
  (0x016b
  RAPTORHTML.DLL + 0x25c9a
  (0x016b5c9a)
  RAPTORHTML.DLL + 0x26556
  (0x016b6556)
  RAPTORHTML.DLL + 0x25d74
  (0x016b5d74)
  RAPTORHTML.DLL + 0x2d163
  (0x016bd163)
  RAPTORHTML.DLL + 0x2d04b
  (0x016bd04b)
  RAPTORHTML.DLL + 0x25d74
  (0x016b5d74)
  RAPTORHTML.DLL + 0x25c9a
  (0x016b5c9a)
  RAPTORHTML.DLL + 0x26556
  (0x016b6556)
  RAPTORHTML.DLL + 0x25d74
  (0x016b5d
  RAPTORHTML.DLL + 0x25c9a
  (0x016b5c9a)
  RAPTORHTML.DLL + 0x69931
  (0x016f9931)
  RAPTORHTML.DLL + 0x20de0
  (0x016b0de0)
  nsView::Paint
  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 286]
  nsViewManager::RenderView
  [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1279]
  nsViewManager::RenderViews
  [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 812]
  nsViewManager::Refresh
  [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 521]
  nsViewManager::DispatchEvent
  [d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1646]
  HandleEvent
  [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 67]
  nsWindow::DispatchEvent
  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 414]
  nsWindow::DispatchWindowEvent
  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 431]
  nsWindow::OnPaint
  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2802]
  nsWindow::ProcessMessage
  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2168]
  nsWindow::WindowProc
  [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 475]
  KERNEL32.DLL + 0x3663
  (0xbff73663)
  KERNEL32.DLL + 0x22894
  (0xbff92894)
  0x00788c64

Updated

19 years ago
Severity: normal → critical
QA Contact: 3853 → 3819

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
Is this the apprunner or viewer? What is the test url? Can I get a debug build
stack trace? Of course this doesn't happen for *me* so I need more info folks.

Comment 3

19 years ago
RAPTORHTML.DLL/RAPTORHTML.DBG is not available to talkback system. I will
work with leaf to get this done.
Shiva
(Reporter)

Comment 4

19 years ago
Hmmm, Kipp, I can't help you much here. There is no test URL, as the crash is on
start-up. And it is happening using apprunner - viewer doesn't even actually
come with the windows builds that QA gets. I was under the impression that with
talkback reports these type of crashes could be debugged fairly well even when
not reproducible by the developer, but apparently there is a problem.
This may be a win95 specific problem - is there any other way for me to help
here?
(Assignee)

Updated

19 years ago
(Assignee)

Comment 5

19 years ago
ckritzer also sent in a talkback crash on start up with this stack..
"Re-launching product after product crashed."
 Call Stack:    (Signature = GetChar f61b8a6d)
  GetChar     [d:\builds\seamonkey\mozilla\js\src\jsscan.c, line 369]
  js_GetToken [d:\builds\seamonkey\mozilla\js\src\jsscan.c, line 1013]
  js_Parse    [d:\builds\seamonkey\mozilla\js\src\jsparse.c, line 212]
  0x00b44d80
  0x00b515f0
  0x00b68e6

The startup URL is now set to a network file in recent builds.
http://www.mozilla.org/quality/smoketests/
(Reporter)

Updated

19 years ago
Whiteboard: still seeing in 5/13 build

Comment 6

19 years ago
Me, too, starting up with apprunner -mail only, on Win95. May 14 build.
See tracking IDs
ENN57EPV
ENN58PYJ
ENN59GFA
Sporadic in appearance...maybe one out of every four or five startups. Can't
find a pattern.
I'm seeing frequent startup crashes in Windows 95 too.  It seems it often
happens the first time I run apprunner and then it works the second time.

Comment 8

19 years ago
the following report will give the jist of all the crashes relates to startup.

http://cyclone.mcom.com/reports/reporttemplate.cfm?style=1&reportID=1588
Incident IDs relates to startup crash  8532297,8532295, 8532294

Source code line relates to the crash
:\builds\seamonkey\mozilla\gfx\src\windows\nsRenderingContextWin.cpp
line no 1659

height = NSToCoordRound(mP2T * aImage->GetImage());
(Assignee)

Updated

19 years ago
Whiteboard: still seeing in 5/13 build → top talkback problem -still seeing in 5/13 build
Target Milestone: M6
(Assignee)

Comment 9

19 years ago
Kipp are you still looking at bugs today ;-)

If not could we get peterl or rickg to look at this?
Its moving up the later on the top 10 talkback reports...

we need to figure this out by M6...

1652 michaelp 3.59 NS_IMETHODIMP nsRenderingContextWin :: DrawImage(nsIImage
*aImage, nscoord aX, nscoord aY)
1653 kipp     1.1  {
1654                 NS_PRECONDITION(PR_TRUE == mInitialized, "!initialized");
1655
1656                 nscoord width, height;
1657

1658 peterl   3.25   width = NSToCoordRound(mP2T * aImage->GetWidth());
1659                 height = NSToCoordRound(mP2T * aImage->GetHeight());
1660 kipp     1.1
1661 michaelp 3.59   return DrawImage(aImage, aX, aY, width, height);
1662 kipp     1.1  }
1663
FWIW I've been using viewer.exe all day today and it has not crashed once.
I just loaded six simultaneous copies of apprunner.exe and that didn't crash
either (although it did take around 35 minutes for them all to load...).

This is using Windows98 on a P5/120; build of 1999-05-14.
(Reporter)

Comment 11

19 years ago
It seems to be a win95 specific problem - I still see it in 5/17 builds.
(Reporter)

Comment 12

19 years ago
*** Bug 6598 has been marked as a duplicate of this bug. ***

Comment 13

19 years ago
Yes, it's a Win95 problem.  We see this in the Mail QA group on more than one
machine.

Comment 14

19 years ago
When submitting the crash to talkback can you please include 'startup crash' as
the starting of the comment. This will help in analysing the crash.
(Assignee)

Updated

19 years ago
Assignee: kipp → rickg
Status: ASSIGNED → NEW
(Assignee)

Comment 15

19 years ago
the randomness and varied stack traces in this bug is going to
make it hard to deal with.  we may need to close out this one
and divide it up into several bugs.  Rick any thoughts?

Updated

19 years ago
Assignee: rickg → chofmann

Comment 16

19 years ago
There appear to be seperate crashes here (views, javascript, etc), as Chris
points out. Let's back up and start again. I'm asking ChrisH to own the problem
of getting QA to seperate the various bugs for us to tackle. One other thing:
don't waste your time in viewer -- I only want bugs in Apprunner.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 17

19 years ago
This bug was originally filed for the start-up crash in raptorgfxwin.dll. I will
open a new bug for that and mark this as a dup of it. No one is allowed to touch
the new bug unless it involves raptorgfxwin.dll :-)

*** This bug has been marked as a duplicate of 6934 ***

Comment 18

19 years ago
Note: the Windows-generated crash popup windows for the crashes I reported as
tracking IDs did say it was in raptorgfxwin.dll, though it doesn't appear in
talkback's call stack. Use 'em if you like, disregard 'em if you like.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 19

19 years ago
verified as a dup

Comment 20

19 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.