A loading PNG can become corrupted part way through

RESOLVED DUPLICATE of bug 617123

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 617123
8 years ago
8 years ago

People

(Reporter: Lozzy, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101208 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.0b8pre) Gecko/20101208 Firefox/4.0b8pre

I first noticed this while loading a page with a large number of PNGs with fairly large sizes. I've noticed the same kind of issue for a while now in Fx4 nightlies. If you begin loading the page with images, stop it partway through, then hit reload, the rest of the image will load incorrectly.

Reproducible: Always

Steps to Reproduce:
1. Visit a page with large PNG images (example 1; http://forums.techpowerup.com/showthread.php?t=116061&page=3 Example 2; http://forums.hologfx.com/index.php?topic=105 Example 3; http://jayn0.deviantart.com/art/Halo-Reach-Perspective-176979898)
2. Wait for the images to load partially
3. Stop the page loading before they have finished loading
4. Hit reload
Actual Results:  
Top parts of the image will be correct, the rest will appear to continue loading but will display incorrectly.

Expected Results:  
Images should appear as usual, possibly after reloading from the beginning of the image

This doesn't just happen upon being forced; it can also happen on a natural page load, especially when working with a slow or overloaded network. This is what happened to me previously. Some images loaded fine, but others stopped loading part way through. When I hit the reload button the issue presented itself. (By the way, this is my first bug submission, so hopefully I did good!)
(Reporter)

Comment 1

8 years ago
Created attachment 496538 [details]
Screenshot of the issue as seen in example 3

As seen here; http://jayn0.deviantart.com/art/Halo-Reach-Perspective-176979898
Confirmed on Linux (Ubuntu 10.10 x86_64) -- I hit this the second time I tried the STR at the deviantart URL.  (I had to artificially limit my connection speed with the command "sudo wondershaper eth0 100 100" so the image wouldn't just load instantly. :) )
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101208 Firefox/4.0b8pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Version: unspecified → Trunk
Created attachment 496551 [details]
screenshot on ubuntu
NOTE: after I got the above screenshot, the image was busted *in my image cache* -- so I'd get the exact same busted image (loading instantly, from cache) if I tried to view the image directly or reload the forum page.

I had to shift-reload the image (or any page that uses it) in order to purge the busted version from my cache.
blocking2.0: --- → ?
(Reporter)

Comment 5

8 years ago
Indeed, it definitely seems to have some kind of effect on the cached version of the images. Forgot to mention that. Possible that the cache could be the/a part of the cause?
OS: All → Windows 7
Version: Trunk → unspecified
OS: Windows 7 → All
Version: unspecified → Trunk

Comment 6

8 years ago
This is potentially a dup of bug 617123.
I'm going to say that it is a dup of that bug. If it turns out not to be, please reopen.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 617123
Component: ImageLib → Networking
QA Contact: imagelib → networking

Updated

8 years ago
blocking2.0: ? → betaN+
You need to log in before you can comment on or make changes to this bug.