Changing Sync Key causes unknown sync error

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 496574 [details]
sync log of client that changed key

Seen testing 1.6b2 against 3.5.16 on Mac and Linux. Once in this state, I think the account is stuck.  Reset Sync doesn't help.

STR:
0) Setup an account on two machines
1) On one client go to the Sync Preferences > Manage Account > My Sync Key
2) "Generate" a new Sync, then click Change Sync Key.

Tested results:
Shortly on this client, a sync error appears of the unknown sync error type.
No amount of retries resolve the issue. 

Attempts to sync from the other client also produce the same sync error

Expected Results:
All data is uploaded to the server using the new Sync Key.

The second client informed of need to update sync key.
Might be a consequence of Bug 617709. Due to land shortly (at least, the part that might affect this...).
(Reporter)

Comment 2

8 years ago
Yep, this one is fixed by changes in that bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

8 years ago
Verified with 3.5.16 with Sync 1.6b3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.