Closed Bug 618355 Opened 9 years ago Closed 9 years ago

Find in page lets you search for two/three letter words maximum

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0+)

VERIFIED FIXED
Tracking Status
fennec 2.0+ ---

People

(Reporter: ehsan, Assigned: vingtetun)

References

Details

STR:

1. Go to firefox's wikipedia page.  The goal is to look for webgl on that page.
2. Invoke find in page, and try to type "webgl".
3. If you're really fast, you'll get to type "web", I sometimes only have enough time to type "we".  Seems like there is a timeout in effect.

When the keyboard disappears and the find operation begins, the most natural thing is to try to resume typing where you left off.  But tapping the find text box again doesn't invoke the keyboard.  You have to clear the term and start over.
tracking-fennec: --- → ?
the search box should try to search for text after a timeout, just like in other Firefox code. The problem here is that the focus moves somehwere (content maybe?) and the keyboard closes. We had a bug about this happening. I don't know if it was FIXED or is still open.
Summary: Find in page lets you search for two/three letter words maximum! → Find in page lets you search for two/three letter words maximum
(In reply to comment #1)
> the search box should try to search for text after a timeout, just like in
> other Firefox code. The problem here is that the focus moves somehwere (content
> maybe?) and the keyboard closes. We had a bug about this happening. I don't
> know if it was FIXED or is still open.

Yes.  Also, when I re-tap on it, I should be able to type again.
Assignee: nobody → 21
tracking-fennec: ? → 2.0+
OS: Mac OS X → All
Hardware: x86 → All
I can't reproduce this with today's nightly
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Most likely fixed by backing out bug 612128
Depends on: 612128
Resolution: WORKSFORME → FIXED
This works for me on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101227 Namoroka/4.0b9pre Fennec/4.0b4pre


Ehsan, is this working for you now?
Status: RESOLVED → VERIFIED
(In reply to comment #5)
> This works for me on build:
> 
> Mozilla/5.0 (Android; Linux armv71; rv:2.0b9pre) Gecko/20101227
> Namoroka/4.0b9pre Fennec/4.0b4pre
> 
> Ehsan, is this working for you now?

Yes.
You need to log in before you can comment on or make changes to this bug.