Last Comment Bug 618365 - 3 "WARNING: Failed to get XPConnect?!: 'rts', file ../../../xpcom/base/nsCycleCollector.cpp, line 3415"
: 3 "WARNING: Failed to get XPConnect?!: 'rts', file ../../../xpcom/base/nsCycl...
Status: VERIFIED FIXED
[fixed by bug 626768]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla2.0b11
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
: Nathan Froyd [:froydnj]
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 626768
Blocks: 617967 580096 594263 618695
  Show dependency treegraph
 
Reported: 2010-12-10 10:47 PST by Serge Gautherie (:sgautherie)
Modified: 2012-05-22 23:16 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Serge Gautherie (:sgautherie) 2010-12-10 10:47:10 PST
(First noticed in bug 617967.)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1292004418.1292005837.8018.gz&fulltext=1
Linux mozilla-central leak test build on 2010/12/10 10:06:58
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1291989887.1291993512.15084.gz&fulltext=1
OS X 10.5 comm-central-trunk leak test build on 2010/12/10 06:04:47
{
WARNING: Failed to get XPConnect?!: 'rts', file ../../../xpcom/base/nsCycleCollector.cpp, line 3415
WARNING: Failed to get XPConnect?!: 'rts', file ../../../xpcom/base/nsCycleCollector.cpp, line 3415
WARNING: Failed to get XPConnect?!: 'rts', file ../../../xpcom/base/nsCycleCollector.cpp, line 3415
}

This warning was added in bug 580096.
Comment 1 Ben Turner (not reading bugmail, use the needinfo flag!) 2010-12-10 10:59:11 PST
Hm. So the only way this happens is if the process shuts down before our first cycle collection, looks like on XPCOM registration only (passing --register on the command line) and on some of the C++ unit tests. It's not a problem in that case (who cares if we don't CC - we're shutting down), but it would be a problem if it ever happened on a real browser run. I don't know if I want to make that warning go away or not.

Not a major problem in any case, I certainly wouldn't block on it.
Comment 2 Andrew McCreight [:mccr8] 2012-05-22 20:12:26 PDT
The cycle collector no longer produces a warning if it fails to get the JS runtime when calling the GC.
Comment 3 Serge Gautherie (:sgautherie) 2012-05-22 23:16:36 PDT
Right: bug 626768 replaced "Failed to get XPConnect?!".


https://tbpl.mozilla.org/php/getParsedLog.php?id=11974527&tree=Firefox&full=1
Linux mozilla-central leak test build on 2012-05-22 21:26:29 PDT for push 36e938e51481

No "Failed to get JS runtime!" nor "Cannot cycle collect if GC has not run first!" :-)

V.Fixed

Note You need to log in before you can comment on or make changes to this bug.