Wrong host mentioned in error message

RESOLVED WORKSFORME

Status

()

P3
minor
RESOLVED WORKSFORME
18 years ago
6 years ago

People

(Reporter: cesarb, Assigned: neeti)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-test10 i686; en-US; m18) Gecko/20001130
BuildID:    2000113008

If the redirected-to site refuses a connection, the error message incorrectly
says the redirecting site is to blame.

Reproducible: Always
Steps to Reproduce:
1. Get a 2.4 Linux kernel with ECN enabled (this is needed to make www.zdnet.com
refuse the connection)
2. Go to the URL

Actual Results:  "The connection was refused when attempting to contact
www.google.com"
The statusbar shows a successful connection to www.google.com and the attempt to
load www.zdnet.com.

Expected Results:  Showed www.zdnet.com as the one to blame at the error message.

ECN (Explicit Congestion Notification) is a recent standard that uses two of the
formerly "reserved" bits in the TCP header. This makes some broken firewalls
ignore or RST the connection. I think here we're getting an RST (since it's
faster than a timeout). I think it might be possible to reproduce the bug by
pointing the redirect to a closed port.

Comment 1

18 years ago
Confirming. You don't need to use linux2.4 - just manually edit the url to point
it at a host which doesn't accept http connections. I used a usyd internal-only
host which is down ATM that I could get to without a proxy server - you won't
see this if you're using a proxy, because you'll get an error generated by the
proxy instead. I've changed the url to cvs.mozilla.org, which doesn't accept
http connections, and so should exhibit the same problem.

Also see bug 19073.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
networking?
Assignee: asa → neeti
Severity: minor → enhancement
Component: Browser-General → Networking
QA Contact: doronr → tever
Summary: Bogus error message → [RFE] Proper Support for ECN - Explicit Congestion Notification

Comment 3

18 years ago
Networking, because thats where the error comes from, but ECN is a red herring
with this - its just a kernel level networking protocol which is incorrectly
blocked by some firewalls (see http://lwn.net/2000/0914/kernel.php3 - at the end).

Connecting via a redirect to a host which doesn't answer for any reason (like
cvs.mozilla.org, because it doesn't run a web server AFAIK) will do to duplicate
this - see URL in the bug report.
Severity: enhancement → minor
Summary: [RFE] Proper Support for ECN - Explicit Congestion Notification → Wrong host mentioned in error message
(Assignee)

Updated

18 years ago
Blocks: 61685

Comment 4

18 years ago
*** Bug 68596 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: --- → Future

Comment 5

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Reporter)

Comment 6

17 years ago
I have the slight impression that someone fixed this bug and forgot to close it,
or that it got fixed by accident.

WFM 2001090608

QA please verify
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.