Cannot delete image in gallery

VERIFIED FIXED in 2.4

Status

support.mozilla.org
Knowledge Base Software
P1
normal
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: JasnaPaka, Assigned: erik)

Tracking

unspecified
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
How to reproduce:
1) Visit https://master.support.mozilla.com/en-US/gallery/image/5253
2) Click on the button "Delete this image".

Result:
Error message is showed.

"An Error Occurred

Oh, no! It looks like an unexpected error occurred. We've already notified the site administrators. Please try again now, or in a few minutes."
Here's the relevant part of the stack trace:

  File "/data/www/master.support.mozilla.com/kitsune/apps/gallery/templates/gallery/confirm_media_delete.html", line 5, in template
    {% set delete_confirm = _('Are you sure you want to delete this image?') }}


Whoever reviewed this code must not have run it, which makes me sad.
Priority: -- → P1
Target Milestone: --- → 2.4
(Assignee)

Updated

7 years ago
Assignee: nobody → erik
(Assignee)

Comment 2

7 years ago
Fixed but waiting for 2.4 to be tagged before committing, since it's more QA load.
Target Milestone: 2.4 → 2.4.1
(Assignee)

Comment 3

7 years ago
Okay, Rebecca has time.
Target Milestone: 2.4.1 → 2.4
(Assignee)

Comment 4

7 years ago
Landed in https://github.com/jsocol/kitsune/commit/3844d67cfa93bba1d22b46efb2229207f492ff08.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified fixed
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.