All users were logged out of Bugzilla on October 13th, 2018

pressing space bar on non-focused page causes crash

VERIFIED DUPLICATE of bug 59930

Status

P3
normal
VERIFIED DUPLICATE of bug 59930
18 years ago
14 years ago

People

(Reporter: michael_bourgon, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 95
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you swap between pages in Mozilla, pressing the space bar will cause a crash.
Expected behavior: scroll down one page

How to repeat (I can pretty much repeat this every time):
open a window, go to a web page.  open another window, go to that page as well.
 [Alt]-[Tab] back to the first window.  Press the space bar.

What I think is happening:
focus when you [Alt]-[Tab] in (and this may occur if you chose from the taskbar)
is not set in the window itself.  (I normally cruise with only the personal
toolbar up, but it may not matter.)  When you hit the spacebar, Moz doesn't know
what to do, so it crashes.

Solution: auto set the focus on a window when it becomes the active window.

Comment 1

18 years ago
Reporter: please use a talkback build so that we can get a crash incident. Also 
what build id? Please use a nightly [currently i'd recommend a build from last 
weekend].

Updated

18 years ago
Keywords: crash

Comment 2

18 years ago
Is this a dup of bug 59930 ?
Fabian.
(Reporter)

Comment 3

18 years ago
Timeless: I was using a talkback build.  Unfortunately I don't think I added my
username to the crash reporter, but if you do a search on "space" and "crash"
you should get several from IP address 24.4.21.182.  (Sorry I didn't say
anything, the bug submission page said (and showed) my build number.  I was
using a build from this weekend.  I will get it to crash several times this
morning using the most current build, and I'll make sure I set my email address
correctly (this time).  :)

Fabian: yes, I think this is a duplicate of 59930.  It definitely meets the
criteria set by the other people, though I don't know if it's the same bug that
the original submitter had.
(Assignee)

Comment 4

18 years ago
talkback from your crash:

   nsXBLPrototypeHandler::ExecuteHandler
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLPrototypeHandler.cpp, line 297]
     nsXBLWindowHandler::WalkHandlersInternal
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowHandler.cpp, line 165]
     nsXBLWindowKeyHandler::WalkHandlers
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowKeyHandler.cpp, line 124]
     nsXBLWindowKeyHandler::KeyPress
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsXBLWindowKeyHandler.cpp, line 140]
     nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventListenerManager.cpp, line
1178]
     nsWindowRoot::HandleChromeEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsWindowRoot.cpp, line 187]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsXULDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 2011]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3477]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 3469]
     nsXULElement::HandleChromeEvent
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULElement.cpp, line 4417]
     GlobalWindowImpl::HandleDOMEvent
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 582]
     nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 3041]
     nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\base\src\nsGenericElement.cpp, line 1419]
     nsHTMLParamElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\layout\html\content\src\nsHTMLParamElement.cpp,
line 188]
     PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4878]
     PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4813]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 379]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 352]
     nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 352]
     nsViewManager2::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1439]
     HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 690]
     nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 707]
     nsWindow::DispatchKeyEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2298]
     nsWindow::OnChar
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2421]
     nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2846]
     nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 963]
     USER32.dll + 0x1820 (0x77e71820)
     0x00390001
(Assignee)

Comment 5

18 years ago
indeed it looks like bug 59930

*** This bug has been marked as a duplicate of 59930 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe of bug 59930: "Crash on hitting spacebar after browsing for a
while"
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.