Multiple add-on entries in list view when downloading an update

VERIFIED FIXED in mozilla2.0b10

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: whimboo, Assigned: Unfocused)

Tracking

({regression})

Trunk
mozilla2.0b10
regression
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 497203 [details]
screenshot

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101204 Firefox/4.0b8pre ID:20101204030328

Downloading an available update while the extension pane is open, causes multiple entries to appear. See the screenshot.

Steps:
1. Install an older version of an add-on (i.e. Adblock 1.3.1)
2. Switch to manual updating add-ons
3. Search for updates
4. Update with the extension list open
(Reporter)

Comment 1

7 years ago
Asking for blocking, because it's part of the primary ui in the add-ons manager and users who have enabled manual updates will always see that behavior, when an update is initiated via the extensions/appearance list view.
blocking2.0: --- → ?
Likely a regression from bug 591663
Blocks: 591663
(Reporter)

Updated

7 years ago
Keywords: regression
Broken-y UI -> blocking+.
blocking2.0: ? → final+
Can you take this Blair? Basically the last unowned non-trivial add-ons manager blocker right now
Assignee: nobody → bmcbride
Taken!
Status: NEW → ASSIGNED
Created attachment 502643 [details] [diff] [review]
Patch v1

Very big and very complicated patch.
Attachment #502643 - Flags: review?(dtownsend)
Whiteboard: [has patch][needs review Mossop]
Whiteboard: [has patch][needs review Mossop] → [has patch][needs review Mossop][soft blocker]
Attachment #502643 - Flags: review?(dtownsend) → review+
Whiteboard: [has patch][needs review Mossop][soft blocker] → [has patch][soft blocker]
Landed: https://hg.mozilla.org/mozilla-central/rev/314f902db8bc

Automated tests cover this well.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Whiteboard: [has patch][soft blocker] → [soft blocker]
Target Milestone: --- → mozilla2.0b10
Whiteboard: [soft blocker] → [softblocker]
(Reporter)

Comment 8

6 years ago
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre ID:20110114030359
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.