"Session restore" not available after OS crash.

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Michal, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9

After initiation of the system shutdown, Firefox offered a dialog box with the option to "Save and quit" button which was pressed. System crushed immediately after. On the next reboot Firefox opened just the home page, without any option to restore previous sessions.

Reproducible: Always

Steps to Reproduce:
1.I believe that crushing the system immediately after pressing "Save and quit" button might reproduce the behavior.
2.
3.



Having an explicit option to "Restore Last Session" in the drop-down menus would be prudent.
"Two phase commit" concept employed for the "Save and quit" button would likely eliminate possible racing condition against the OS actions.

Because some of the pages opened in the multiple tabs were not bookmarked and subsequent attempts to search for them failed, a significant loss of information occurred.

Even though an unrecoverable loss of information/data resulted, I believe that rating Major instead of Critical would be more appropriate.

Regards,

Michal
Can you reproduce the Issue on a more recent Firefox 3.6.x Version?

If you inspect your sessionstore.js *before* restarting Firefox, does it contain the missing Sites?
Severity: major → normal
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

7 years ago

(In reply to comment #1)
> Can you reproduce the Issue on a more recent Firefox 3.6.x Version?
> 
> If you inspect your sessionstore.js *before* restarting Firefox, does it
> contain the missing Sites?

Event occurred in Firefox 3.6.9.

Reproduction of the behavior is tricky because when the event occurred, system crashed/"shutdown unexpectedly quickly" immediately (like milliseconds?) after I have pressed "save and quit" button.

No, did not review nsSessionStore.js because I did not expect problems and I just started Firefox to get to "restore session" option, as always before.

Content of the nsSessionStore.js did not have any recollection of the missing sites, after FF automatically opened "home page" on the first start following reboot (may be having a "buffer" of previous 3-4 versions would help as a temporary solution?).

Best regards,

Michal
In Firefox 4.0b8 we have the option in the History menu to Restore Previous Session.  For now, resolving WORKSFORME.  Please reopen if this happens to you again on the latest version of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.