Last Comment Bug 618948 - foo.oninput and foo.oninvalid should be working
: foo.oninput and foo.oninvalid should be working
Status: RESOLVED FIXED
: html5
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla2.0b9
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-13 16:37 PST by Mounir Lamouri (:mounir)
Modified: 2010-12-22 18:41 PST (History)
2 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (7.07 KB, patch)
2010-12-21 06:42 PST, Mounir Lamouri (:mounir)
bugs: review+
jonas: approval2.0+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2010-12-13 16:37:26 PST
It looks like a lot of properties to define event handlers are not available.

See the exhaustive list here:
http://www.whatwg.org/specs/web-apps/current-work/multipage/elements.html#elements-in-the-dom
Comment 1 Olli Pettay [:smaug] (vacation Aug 25-28) 2010-12-13 16:41:33 PST
I think this is a dup. Currently we add onfoo listeners in nsDOMClassInfo, but
we should change that.
Comment 2 Mounir Lamouri (:mounir) 2010-12-13 16:45:58 PST
(In reply to comment #1)
> I think this is a dup. Currently we add onfoo listeners in nsDOMClassInfo, but
> we should change that.

A dup of which bug?

Actually, this bug could be spitted in two:
1. oninput, oninvalid, onchange (and probably some other) properties doesn't work if set.
2. all on<eventName> are not valid properties of HTMLElement.

Is 2. the dup?
Comment 3 Mounir Lamouri (:mounir) 2010-12-21 06:42:46 PST
Created attachment 499013 [details] [diff] [review]
Patch v1
Comment 4 Mounir Lamouri (:mounir) 2010-12-22 05:15:36 PST
Approval request: there is no way to check if oninput or oninvalid is supported by Firefox by an author because |"oninput" in inputElement| will always return false for the moment. I think we should make sure it will work given that we support the events.
Comment 5 Mounir Lamouri (:mounir) 2010-12-22 18:41:12 PST
Pushed:
https://hg.mozilla.org/mozilla-central/rev/59203494cf75

Note You need to log in before you can comment on or make changes to this bug.