The default bug view has changed. See this FAQ.

'* comm-1.9.1 unit test' fail to 'buildsymbols' and 'package', since upgrade to buildbot 0.8

RESOLVED FIXED

Status

SeaMonkey
Build Config
--
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: Robert Kaiser)

Tracking

({fixed-seamonkey2.0.12, regression})

SeaMonkey 2.0 Branch
fixed-seamonkey2.0.12, regression
Bug Flags:
blocking-seamonkey2.0.12 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292221103.1292224885.5419.gz
Linux comm-1.9.1 unit test on 2010/12/12 22:18:23
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292221171.1292223587.32414.gz
OS X 10.5 comm-1.9.1 unit test on 2010/12/12 22:19:31
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292221103.1292226666.12169.gz
WINNT 5.2 comm-1.9.1 unit test on 2010/12/12 22:18:23
{
make: *** No rule to make target `buildsymbols'.  Stop.
make: *** No rule to make target `package'.  Stop.
}

Related to builbot change to v0.8 !?
Flags: blocking-seamonkey2.0.11?
The odd part is, I see buildsymbols on the c-191/Makefile.in so I'm not sure how its NOT finding the target
Flags: blocking-seamonkey2.0.11? → blocking-seamonkey2.0.12+
(Reporter)

Updated

6 years ago
Blocks: 567035
(Reporter)

Comment 2

6 years ago
It looks like some of the environment is missing:

Before:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292066985.1292074990.31222.gz&fulltext=1
Linux comm-1.9.1 unit test on 2010/12/11 03:29:45
s: cb-sea-linux-tbox
{
======== BuildStep started ========
'make buildsymbols'
=== Output ===
make buildsymbols
 in dir /builds/slave/comm-1.9.1-linux-unittest/build/objdir (timeout 1200 secs)
 watching logfiles {}
 argv: ['make', 'buildsymbols']
 environment:
  CCACHE_DIR=/builds/ccache
  CCACHE_UMASK=002
  CVS_RSH=ssh
  DISPLAY=:2
  G_BROKEN_FILENAMES=1
  HISTSIZE=1000
  HOME=/home/seabld
  HOSTNAME=cb-sea-linux-tbox.sj.mozilla.com
  INPUTRC=/etc/inputrc
  JAVA_HOME=/tools/jdk
  LANG=en_US.UTF-8
  LESSOPEN=|/usr/bin/lesspipe.sh %s
  LOGNAME=seabld
  LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
  MAIL=/var/spool/mail/seabld
  MINIDUMP_STACKWALK=/builds/slave/comm-1.9.1-linux-unittest/tools/breakpad/linux/minidump_stackwalk
  MOZ_NO_REMOTE=1
  MOZ_OBJDIR=objdir
  NO_FAIL_ON_TEST_ERRORS=1
  PATH=/opt/local/bin:/tools/python/bin:/tools/buildbot/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/home/seabld/bin
  PWD=/builds/slave/comm-1.9.1-linux-unittest/build/objdir
  SHELL=/bin/bash
  SHLVL=1
  SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
  TBOX_CLIENT_CVS_DIR=/builds/tinderbox/mozilla/tools
  TERM=linux
  USER=seabld
  _=/tools/buildbot/bin/buildbot
 closing stdin
 using PTY: True
}

After:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292300129.1292303960.23571.gz&fulltext=1
Linux comm-1.9.1 unit test on 2010/12/13 20:15:29
s: cb-seamonkey-linux-02
{
======== BuildStep started ========
'make buildsymbols' failed
=== Output ===
make buildsymbols
 in dir /builds/slave/comm-1.9.1-linux-unittest/build/objdir (timeout 1200 secs)
 watching logfiles {}
 argv: ['make', 'buildsymbols']
 environment:
  CVS_RSH=ssh
  G_BROKEN_FILENAMES=1
  HISTSIZE=1000
  HOME=/home/seabld
  HOSTNAME=cb-seamonkey-linux-02
  INPUTRC=/etc/inputrc
  LANG=en_US.UTF-8
  LESSOPEN=|/usr/bin/lesspipe.sh %s
  LOGNAME=seabld
  LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=01;32:*.cmd=01;32:*.exe=01;32:*.com=01;32:*.btm=01;32:*.bat=01;32:*.sh=01;32:*.csh=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tz=01;31:*.rpm=01;31:*.cpio=01;31:*.jpg=01;35:*.gif=01;35:*.bmp=01;35:*.xbm=01;35:*.xpm=01;35:*.png=01;35:*.tif=01;35:
  MAIL=/var/spool/mail/seabld
  PATH=/opt/local/bin:/tools/python/bin:/tools/buildbot/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/home/seabld/bin
  PWD=/builds/slave/comm-1.9.1-linux-unittest/build/objdir
  SHELL=/bin/bash
  SHLVL=1
  SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
  TERM=linux
  USER=seabld
  _=/tools/buildbot/bin/buildbot
 closing stdin
 using PTY: True
}
No CCACHE_*, MOZ_OBJDIR, etc.
Summary: '* comm-1.9.1 unit test' fail to 'buildsymbols' and 'package', since 2010.12.12 → '* comm-1.9.1 unit test' fail to 'buildsymbols' and 'package', since upgrade to buildbot 0.8
(Assignee)

Comment 3

6 years ago
Hmm, well, the Firefox guys did some changes that might have compromised unittest build support, esp. on the 1.9.1 branch. Still, I'll need to look into this and figure it out for us if possible.
(Assignee)

Comment 4

6 years ago
I hope that http://hg.mozilla.org/build/buildbotcustom/rev/dcad78364141 fixes this, will need to try with more build runs.
(Assignee)

Comment 5

6 years ago
Looks good now.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Updated

6 years ago
Assignee: nobody → kairo
Keywords: fixed-seamonkey2.0.12
(Reporter)

Comment 6

6 years ago
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey2.0&maxdate=1292796121&hours=24&legend=0&norules=1
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292712637.1292717671.13638.gz
Linux comm-1.9.1 unit test on 2010/12/18 14:50:37

verified-seamonkey2.0.12
You need to log in before you can comment on or make changes to this bug.