Closed Bug 619006 Opened 9 years ago Closed 9 years ago

[SeaMonkey] 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file", since upgrade to builbot 0.8

Categories

(SeaMonkey :: Release Engineering, defect, P1, major)

All
Linux

Tracking

(Not tracked)

VERIFIED FIXED
seamonkey2.1b2

People

(Reporter: sgautherie, Assigned: kairo)

References

Details

Attachments

(1 obsolete file)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292221103.1292225142.6235.gz
Linux comm-1.9.1 build on 2010/12/12 22:18:23
{
======== BuildStep started ========
no change
=== Output ===
python /builds/slave/comm-1.9.1-linux/tools/buildfarm/utils/count_ctors.py objdir/dist/bin/libxul.so
...
readelf: Error: 'objdir/dist/bin/libxul.so': No such file
None	objdir/dist/bin/libxul.so
program finished with exit code 0
}

Related to builbot change to v0.8 !?
Flags: blocking-seamonkey2.0.11?
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1292285113.1292286316.6008.gz
Linux comm-central-trunk build on 2010/12/13 16:05:13

Trunk too.
blocking-seamonkey2.1: --- → ?
Summary: 'Linux comm-1.9.1 build' fails with "Error: 'objdir/dist/bin/libxul.so': No such file" → 'Linux comm-* build' fails with "Error: 'objdir/dist/bin/libxul.so': No such file"
Version: SeaMonkey 2.0 Branch → Trunk
Hum,

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1292287877.1292294137.10095.gz
Linux comm-central-trunk build on 2010/12/13 16:51:17
has the same failure, yet is green :-/

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1292283352.1292287124.9342.gz
Linux x86-64 comm-central-trunk build on 2010/12/13 15:35:52
too.

MacOSX and Windows seem fine.
Severity: blocker → major
blocking-seamonkey2.1: ? → ---
Flags: blocking-seamonkey2.0.11?
OS: All → Linux
Summary: 'Linux comm-* build' fails with "Error: 'objdir/dist/bin/libxul.so': No such file" → 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file"
What makes builds actually "fail" is in fact
Bug 619009 - Lots of "graph server post results complete failed", since 2010.12.12
(In reply to comment #0)
> python /builds/slave/comm-1.9.1-linux/tools/buildfarm/utils/count_ctors.py
> objdir/dist/bin/libxul.so

Ah, I guess this should rather be objdir/mozilla/dist/bin/libxul.so.

See
http://mxr.mozilla.org/build/search?string=libxul.so&case=1&find=%2Fprocess%2Ffactory.py
Untested, but copied from a few lines below...
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Attachment #497437 - Flags: review?(bhearsum)
Blocks: 579131
Component: Build Config → Release Engineering
Keywords: regression
Product: SeaMonkey → mozilla.org
QA Contact: build-config → release
Summary: 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file" → [SeaMonkey] 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file"
Version: Trunk → other
Comment on attachment 497437 [details] [diff] [review]
(Av1) s/objdir/mozillaObjdir/
[Duplicated by bug 619975]

I think we want KaiRo to peek at this too...
Attachment #497437 - Flags: feedback?(kairo)
(In reply to comment #2)
> same failure, yet is green :-/

Ben, shouldn't this step have warnOnFailure=True and/or haltOnFailure=True or the like too? So that this error could be explicitly noticed...
Comment on attachment 497437 [details] [diff] [review]
(Av1) s/objdir/mozillaObjdir/
[Duplicated by bug 619975]

That should be it, yes, as it's a factory used by everyone, Ben needs to do the review and we'll need to do a coordinated checkin, though.
Attachment #497437 - Flags: feedback?(kairo) → feedback+
Depends on: 567035
Blocks: 567035
No longer depends on: 567035
Nightlies are affected too:
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1292140801.1292144742.23936.gz&fulltext=1
Linux x86-64 comm-1.9.1 nightly on 2010/12/12 00:00:01
s: cb-seamonkey-linux64-01
{
readelf: Error: 'objdir/dist/bin/libxul.so': No such file
}
Summary: [SeaMonkey] 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file" → [SeaMonkey] 'Linux comm-* build' (silently) reports "Error: 'objdir/dist/bin/libxul.so': No such file", since upgrade to builbot 0.8
Comment on attachment 497437 [details] [diff] [review]
(Av1) s/objdir/mozillaObjdir/
[Duplicated by bug 619975]

Looks ok, needs testing in staging.
Attachment #497437 - Flags: review?(bhearsum) → review+
checkin-needed, or should I simply push it to default?

***

Ben, what about comment 7?
Keywords: checkin-needed
(In reply to comment #11)
> checkin-needed, or should I simply push it to default?
> 
> ***
> 
> Ben, what about comment 7?

No, please don't land it anywhere or mark checkin-needed yet. I'll test this in staging next time I'm doing something else there.
Keywords: checkin-needed
Whiteboard: [c-n: to be tested on staging first]
Whiteboard: [c-n: to be tested on staging first] → [c-n: to be tested on staging first] [ToDo: (answer) comment 7]
Priority: -- → P1
(In reply to comment #12)
> I'll test this in staging next time I'm doing something else there.

Ping.
Attachment #497437 - Attachment description: (Av1) s/objdir/mozillaObjdir/ → (Av1) s/objdir/mozillaObjdir/ [Duplicated by bug 619975]
Attachment #497437 - Attachment is obsolete: true
Yet another case of stalled process which leads to double work (in bug 619975) :-(
Depends on: 619975
Whiteboard: [c-n: to be tested on staging first] [ToDo: (answer) comment 7] → [ToDo: (answer) comment 7]
No longer blocks: 579131
based on c#14 and that this bug wasn't closed (yet) I'm now morphing it into a SeaMonkey releng bug to track the deployment of this buildbot update. Will resolve when its resolved on our production.
Assignee: sgautherie.bz → nobody
Product: mozilla.org → SeaMonkey
QA Contact: release → release
Version: other → Trunk
Assignee: nobody → bugspam.Callek
I just updated buildbotcustom as I checked in the last patch to the repo that we had applied locally, and with the reconfig I also did afterwards, this should be fixed.
Assignee: bugspam.Callek → kairo
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
On
http://tinderbox.mozilla.org/showbuilds.cgi?tree=SeaMonkey&maxdate=1294810489&hours=24&legend=0&norules=1

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1294758558.1294764156.15351.gz
Linux comm-central-trunk build on 2011/01/11 07:09:18
{
readelf: Error: 'objdir/dist/bin/libxul.so': No such file
...
TinderboxPrint: num_ctors: unknown
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1294767933.1294776098.5864.gz
Linux comm-central-trunk build on 2011/01/11 09:45:33
{
329	objdir/mozilla/dist/bin/libxul.so
...
TinderboxPrint: num_ctors: 329
}

V.Fixed (on trunk)
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Whiteboard: [ToDo: (answer) comment 7]
Target Milestone: --- → seamonkey2.1b2
Yet, this is still not fixed on SeaMonkey 2.0...
Depends on: 626232
(In reply to comment #7)
> Ben, shouldn't this step have warnOnFailure=True and/or haltOnFailure=True or
> the like too? So that this error could be explicitly noticed...

I filed bug 626232.
You need to log in before you can comment on or make changes to this bug.