If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[BTN]<button> should softwrap contents

RESOLVED FIXED in mozilla1.9alpha1

Status

()

Core
Layout: Form Controls
--
minor
RESOLVED FIXED
17 years ago
11 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

Trunk
mozilla1.9alpha1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

(Reporter)

Description

17 years ago
If a button's text is long (long enough to make the button longer than the 
content area) but contains spaces, the text should be wrapped to make the 
button narrower.
The best way to do this is probably to implement 'inline-block' (once it is
defined) and then define button in terms of it...

Updated

17 years ago
Status: NEW → ASSIGNED
Summary: <button> should softwrap contents → [BTN]<button> should softwrap contents

Comment 2

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire

Updated

17 years ago
Target Milestone: --- → mozilla1.2
(Reporter)

Comment 3

16 years ago
Sounds related: bug 55285, newlines within <button> (and <input type="button">) 
are displayed.

Updated

16 years ago
Priority: P3 → P2
Target Milestone: mozilla1.2 → Future

Updated

16 years ago
QA Contact: vladimire → tpreston

Comment 4

14 years ago
*** Bug 247580 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: rods → nobody
Status: ASSIGNED → NEW
Depends on: 9458
OS: Windows 98 → All
QA Contact: tpreston → ian
Hardware: PC → All
*** Bug 279860 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
button { max-width: 100%; }

in html.css is a simple patch for this.
Not perfect, but much better than now.
Whiteboard: [reflow-refactor]

Comment 7

12 years ago
Re: https://bugzilla.mozilla.org/show_bug.cgi?id=279860 and http://murent.us/firefoxtest.php

Huh. What'dya know. I made the text flow as desired (at least in Firefox 1.5.0.1/Linux). I set the form's width to 100% (inherit didn't work) and set the button's width to inherit.

So. It would seem that neither FORM nor BUTTON properly handle WIDTH.

Does this help narrow the problem?
(Reporter)

Comment 8

11 years ago
The testcase in the URL field gets wrapped correctly in a fresh build from just after the reflow branch landed.  For comparison, it created a long horizontal scrollbar in a 2006-12-05 nightly build.

-> FIXED by reflow branch landing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 300030
Priority: P2 → --
Resolution: --- → FIXED
Target Milestone: Future → mozilla1.9alpha
(Reporter)

Updated

11 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.