Mozilla halts on Logo Screen

VERIFIED DUPLICATE of bug 53670

Status

P3
critical
VERIFIED DUPLICATE of bug 53670
19 years ago
3 years ago

People

(Reporter: patrick, Assigned: asa)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I just installed the latest nightly of December 3rd and it halts upon startup. 
All you see is the logo screen and that's it. TaskManager doesn't show any 
activity but 16MB RAM used. I experienced the same problem with the nightly of 
November 30th.

Comment 1

19 years ago
wfm with 2000120308 trunk Nt4 Sp6a
(Reporter)

Comment 2

19 years ago
I investigated the bug further and seems to have to do with the profiles. When 
I create a new profile using the profile manager, mozilla starts using that 
profile. The old profile that was there already came from a previous build 
(can't remember which one, must have been of November). It might be important 
to know that the previous build was running with a downloaded theme which 
obviously didn't exist in the new build I grabbed. Maybe that produced the 
effect?
Severity: blocker → critical
Component: Browser-General → Profile Manager BackEnd

Comment 3

19 years ago
There certainly are profile compatibility issues between builds. There are also
profile compatibility between ns6 and mozilla. You should "always" remove all
your files about mozilla before installing a new nightly. I only keep my profile
dir and mozilla finds it when I reinstall it when I install a new nightly.
If mozilla works with a new profile, I wouldn't worry too much.. it happens all
the time to everyone. Reporter do you want to keep this bug open? (And normally,
an old theme shouldn't cause an error, but you never know...)
Thank you,
Fabian.
(Reporter)

Comment 4

19 years ago
I also remove all old Mozilla files everytime I try a new nightly and keep the 
profiles since they are stored in a completely different place. I never had a 
problem until I now tried a new theme and then changed the nightly. Since I 
only have one profile I wasn't even aware of this issue. All I saw was Mozilla 
halting. That definitely caused a lot of confusion. In the same way Mozilla 
during re-installation asks for deletion of old Mozilla files it should take 
care of old profiles. If there is an issue with old themes it should reset the 
profile's theme to a default that works. Just halting is unacceptable. I 
therefore would like to keep this bug open. I think it is critical since first 
time users will never even make it to the browser without having an idea what's 
going on.

Comment 5

19 years ago
we already have a bug for using a theme that can not be found. Please find it 
and mark this as a dupe.
Keywords: qawanted
Whiteboard: DUPEME

Comment 6

19 years ago
Dup of bug 53670. Thanks Timeless.
Fabian.

*** This bug has been marked as a duplicate of 53670 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Updated

19 years ago
Status: RESOLVED → VERIFIED
Keywords: qawanted
Whiteboard: DUPEME

Comment 7

19 years ago
vrfy dupe of bug 53670 "New build won't start if 3rd party theme is used in old 
build [@ nsCSSFrameConstructor::ConstructDocElementFrame]". Thanks fabian
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.