Open Bug 619297 Opened 10 years ago Updated 4 years ago

error when running cmd_findAgain or cmd_findPrevious

Categories

(Toolkit :: Find Toolbar, defect, P5)

defect

Tracking

()

Tracking Status
blocking2.0 --- -

People

(Reporter: testo.moz, Unassigned)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7

Error: this._browser is null
Source File: chrome://global/content/bindings/findbar.xml
Line: 1718

I find this happens when I cause these commands to run just after opening Firefox 4, any further attempts to run it works fine. This is either via the edit menu, keyboard short cut, or an extension that makes toolbar buttons of them.

Reproducible: Always

Steps to Reproduce:
1. Restart Firefox
2. Press ctrl + g
3. Open error console to see error, find bar will not open
Actual Results:  
Error and find bar does not open.

Expected Results:  
Find bar should open.
Product: Core → Firefox
QA Contact: general → general
Confirmed using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre ID:20101215030322

Note: Only recent nightly builds show the error console message, for older builds, the find bar fails to show but no error message is shown in the console.

Last good nightly: 2010-05-19 
First bad nightly: 2010-05-20

Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=145123f19ced&tochange=8d6db7f8fe09

Suspect:
http://hg.mozilla.org/mozilla-central/rev/046c2d2acd3b
Asaf Romano — Bug 566736 - Lazily initialize the findbar. r=gavin.

Provisionally adding blocking bug 566736.

Likely related to bug 567306.
Blocks: 566736
Status: UNCONFIRMED → NEW
Component: General → Find Toolbar
Ever confirmed: true
OS: Linux → All
Product: Firefox → Toolkit
QA Contact: general → fast.find
Hardware: x86_64 → All
Version: unspecified → Trunk
blocking2.0: --- → ?
Keywords: regression
Looks like if you just wait long enough then it works. Not ideal but I wouldn't block on it.
blocking2.0: ? → -
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.