Closed Bug 619522 Opened 10 years ago Closed 10 years ago

getPlatformLocales needs to special case 64-bit platforms

Categories

(Release Engineering :: General, defect, P3)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

Attachments

(1 file, 2 obsolete files)

In Buildbot 0.7.x land we do some munging for 64-bit platforms to make sure that they parse shipped-locales as if they were their 32-bit version. That's done here: http://hg.mozilla.org/build/buildbotcustom/file/917bb931619e/l10n.py#l99

In 0.8.x land, this parsing is done here: http://hg.mozilla.org/build/tools/file/tip/lib/python/release/platforms.py#l43

And there is no such munging. Because of this, we don't get the correct list of locales for 64-bit Mac and Linux. Specifically, ja or ja-JP-mac is missing.

We need to fix this.
Priority: -- → P3
Assignee: nobody → bhearsum
Duplicate of this bug: 619979
I _think_ this is all we need to do for this bug. Will be doing a staging run to confirm.
Attachment #499535 - Flags: review?(rail)
Attachment #499535 - Flags: review?(rail) → review+
Attached patch fix shipped locale munging (obsolete) — Splinter Review
Turns out that shippedlocales2buildbot needed some adjustment!
Attachment #499535 - Attachment is obsolete: true
Attachment #499592 - Flags: review?(rail)
Comment on attachment 499592 [details] [diff] [review]
fix shipped locale munging

>         elif filepath.endswith('.exe'):
>             ret['format'] = 'exe'
>-            m = re.search("(partner-repacks/[-a-zA-Z0-9_]+/|)(win32|mac|linux-i686)/([-a-zA-Z]+)/((?i)%s) Setup (\d+\.\d+(?:\.\d+)?(?:\w+\d+)?(?:\ \w+\ \d+)?)\.exe" % product, filepath)
>+            m = re.search("(partner-repacks/\w+/|)(win32|mac|linux-i686)/([-a-zA-Z]+)/((?i)%s) Setup (\d+\.\d+(?:\.\d+)?(?:\w+\d+)?(?:\ \w+\ \d+)?)\.exe" % product, filepath)

The patch looks good. The only question here, why are we looking for exe files in mac|linux-i686 directories? :)
Attachment #499592 - Flags: review?(rail) → review+
I tested this patch in staging and it worked for ja/linux64 and ja-JP-mac/macosx64 l10n repacks.
Comment on attachment 499592 [details] [diff] [review]
fix shipped locale munging

No good reason probably....this hunk wasn't supposed to changed either, I think I forgot to merge before I diffed!
Same as before, just after a merge to get rid of the signing scripts hunk. Carry review forward.
Attachment #499592 - Attachment is obsolete: true
Attachment #500037 - Flags: review+
This patch worked fine for me in a 3.6.14 staging run.
Comment on attachment 500037 [details] [diff] [review]
same patch after merging

Landed this: changeset:   1941:ccbb8cf73bf4
Attachment #500037 - Flags: checked-in+
We should be all good here in the future.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.