Closed Bug 619773 Opened 9 years ago Closed 9 years ago

WebGL: Crash with blue screen : "NMI: Parity Check / Memory Parity Error" with ATI Mobility FireGL V5700 and driver 8.752.4.0

Categories

(Core :: Graphics, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: thomas, Assigned: bjacob)

References

(Blocks 1 open bug, )

Details

(Keywords: crash, Whiteboard: [softblocker])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7


WebGL: Crash with blue screen : "NMI: Parity Check / Memory Parity Error"


Every time I try to open http://bodybrowser.googlelabs.com with Firefox/4.0b7
I get this blue screen:

----------------------------------------------------------------------------

*** Hardware Malfunction

Call your hardware vendor for support

NMI: Parity Check / Memory Parity Error

*** The system has halted ***

----------------------------------------------------------------------------


Since I never had blue screens on my system before (1 year in use),
this is strange behaviour. 

I guess this is not easy to track and maybe (probably) it's not 
Firefox's problem, but a driver problem (graphics card?!).

Additional info: System is Lenovo W500 notebook 
graphics card: ATI Mobility FireGL V5700
driver version: 8.641.1.1000




Reproducible: Always

Steps to Reproduce:
1. Use Firefox/4.0b7
2. Open URL http://bodybrowser.googlelabs.com
Maybe related to bug 597669 given that's also about WebGL/Leveno laptop/ATI Mobility chipset?

Could you paste the info from the graphics section of about:support please.

Marking as blocking the Ati crashes meta bug 605780.
Blocks: 605780
status2.0: --- → ?
Component: General → Graphics
Keywords: crash
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
blocking2.0: --- → ?
status2.0: ? → ---
This is a hardware or graphic card driver bug that Gecko only triggers
Try the latest nightly (now ANGLE is used to render WebGL) and the latest graphic driver version.
(In reply to comment #1)
> Maybe related to bug 597669 given that's also about WebGL/Leveno laptop/ATI
> Mobility chipset?

I checked bug 597669, in fact it looks exactly the same, 
see bug 597669 comment 19 "NMI: Parity check / memory parity error".

However the solution from bug 597669 comment 21 does not work for me.

I upgraded to the latest graphics drives (same version as in bug 597669),
-- but that does not solve the problem for me.


> Could you paste the info from the graphics section of about:support please.

see below.


(In reply to comment #3)
> Try the latest nightly (now ANGLE is used to render WebGL) and the latest
> graphic driver version.

I installed the latest nightly build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre

No difference, same crash when opening http://bodybrowser.googlelabs.com



Here's the long version... ;)


I installed the newest graphics driver I could find:

http://www-307.ibm.com/pc/support/site.wss/MIGR-73641.html

Version      : 8.752.4-101022a-107489C
Release Date : 2010/11/15


Installer let me upgrade from 8.641.1.0 to 8.752.4


Firefox about:support now shows this :

(same version as in bug 597669 comment 21)

  Graphics

        Adapter Description
        ATI Mobility FireGL V5700

        Vendor ID
        1002

        Device ID
        9591

        Adapter RAM
        512

        Adapter Drivers
        aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64

        Driver Version
        8.752.4.0

        Driver Date

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10



OT: while upgrading the graphics driver, Firefox also crashed,
 --- here's the info I got... ;)
 
AdapterDeviceID: 9591
AdapterVendorID: 1002
Add-ons: pagehacker-nico@nc:1.2,{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}:2.11.21.3,{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:1.3.2,testpilot@labs.mozilla.com:1.0.3,{972ce4c6-7e08-4474-a285-3208198ce6fd}:4.0b7
BuildID: 20101104142426
CrashTime: 1292708899
EMCheckCompatibility: true
FramePoisonBase: 00000000f0de0000
FramePoisonSize: 65536
InstallTime: 1292230166
Notes: AdapterVendorID: 1002, AdapterDeviceID: 9591

ProductName: Firefox
ReleaseChannel: beta
StartupTime: 1292708721
Theme: classic/1.0
Throttleable: 1
URL: jar:file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox%204.0%20Beta%207/omni.jar!/chrome/toolkit/content/global/aboutSupport.xhtml
Vendor: Mozilla
Version: 4.0b7




...so I tried the latest nightly build: 

 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre
 
 This gives one more line under about:config Graphics:
 
 WebGL Renderer: ATI Technologies Inc. -- ATI Mobility FireGL V5700 -- 3.3.10057 Compatibility Profile Context FireGL

...but Firefox (or the graphics driver) still crahes when opening http://bodybrowser.googlelabs.com
https://developer.mozilla.org/En/How_to_get_a_stacktrace_with_windbg

note that you can also use windbg to analyze your bluescreen
FWIW, I get the same bluescreen on my W500 using one of the newest official Mobility Catalyst (10.11 or so). I’ve disabled switchable graphics in the bios and I’m not using the FirePro driver but the one for the regular Mobility-Radeons, thus my card is recognized as HD3650M instead.
Same hardware and completely different drivers results in the same error. I’m starting to wonder what Lenovo/AMD is doing wrong here...
This is starting to feel like a trend. I suspect we should blocklist OpenGL (non-ANGLE WebGL) on this card altogether.
Assignee: nobody → bjacob
Status: UNCONFIRMED → NEW
blocking2.0: ? → final+
Ever confirmed: true
Whiteboard: [softblocker]
Blocks: 623319
I am seeing this too. Lenovo W500 XP latest video driver. This happens in [Mozilla/5.0 (Windows NT 5.1; rv:2.0b11) Gecko/20100101 Firefox/4.0b11] but also in nightly build [Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110214 Firefox/4.0b12pre]. Any site using webgl will BSOD windows. Crash is so abrupt that even system dump is not generated. interesting is that webgl works just fine in google chrome browser.
 @ Michal and anybody who can still reproduce: can you go to about:support, copy to clipboard, and paste there the Graphics section? I would like to see, first of all, if it's using ANGLE.
Summary: WebGL: Crash with blue screen : "NMI: Parity Check / Memory Parity Error" → WebGL: Crash with blue screen : "NMI: Parity Check / Memory Parity Error" with ATI Mobility FireGL V5700 and driver 8.752.4.0
 @ anybody who can reproduce, it could greatly if you followed these steps:

1)  Please download a *debug* build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011-02-15-03-mozilla-central-debug/

2) run Minefield from a terminal with the environment variable MOZ_GL_DEBUG_VERBOSE defined, and log all the output into a text file.

Not sure how to do this with the Windows command prompt, but you can download MSYS (http://www.mingw.org/wiki/msys) and in the MSYS shell, do this command:

  MOZ_GL_DEBUG_VERBOSE=1 /path/to/firefox.exe 2>&1 | tee logfile.txt

3) reproduce the crash, reboot computer, cross fingers that the file logfile.txt was actually flushed to disk before the system hung up...

Attach the resulting logfile.txt here if it's not too big, otherwise compress it or keep only the last, say, 100 kB.
Adapter Description ATI Mobility FireGL V5700
Vendor ID 1002
Device ID9591 
Adapter RAM Unknown
Adapter Drivers ati2dvag
Driver Version 8.771.0.0
Driver Date 8-25-2010
Direct2D Enabled false
DirectWrite Enabled false (0.0.0.0, font cache n/a)
WebGL RendererGoogle Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows 1/1 Direct3D 9
Adapter Description      ATI Mobility FireGL V5700
Vendor ID                1002
Device ID                9591 
Adapter                  512
Adapter Drivers          aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 
                         atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version           8.752.4.0
Driver Date              10-22-2010
Direct2D Enabled         true
DirectWrite Enabled      true (6.1.7600.16699, font cache n/a)
WebGL Renderer           Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)
GPU Accelerated Windows  1/1 Direct3D 10
As windows BSOD the relevant part of log is probably missing. I will try to hack logging to log to file and flush it immed or via UPD but I am not sure it will be any time soon.
OK, the log of GL commands doesn't reveal anything, but the most interesting line is actually this:

WARNING: Couldn't load EGL LIB.: file c:/mozilla-build/source/gfx/thebes/GLContextProviderEGL.cpp, line 355

So that means that this time, it failed to use ANGLE, so it used your desktop OpenGL driver. By contrast, when you go to about:support and it says ANGLE (see comment 11) that measn that the dummy WebGL context created by about:support to test was able to use ANGLE.

So, failing to use ANGLE seems directly related to the crash, and the question is why does that sometimes happen to you.
One way that we could work around this crash is by blacklisting ATI OpenGL drivers on Windows. So either it would succeed to use ANGLE or you just wouldn't get WebGL. At least that would remove the crash. Then we'd need to understand why it sometimes fails to use ANGLE.
Attachment #513231 - Flags: review?(jmuizelaar)
Comment on attachment 513231 [details] [diff] [review]
block ATI OpenGL on Windows

Please add a comment like:
These were added because ANGLE was failing for some reason bug# and we fallback to using opengl in those situations bug#. This was the easiest way to prevent those crashes.
Attachment #513231 - Flags: review?(jmuizelaar) → review+
Blocks: 635861
http://hg.mozilla.org/mozilla-central/rev/a454b4dafe19
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I'm not sure what made the difference - but at least with today's build 
Minefield 4.0b13pre (2011-03-01) I can use http://bodybrowser.googlelabs.com
without any crashes. I was not able to reproduce the crash with this build.
(probably working since a few nightly builds, but I didn't test it... ;)

Additional info: about:support shows exactly the same values as in comment 12.

What I don't understand: I don't see ATI OpenGL blocked, but working?!
(I prefer it this way, no doubt about that ;)


Slightly OT: Google Chrome seems to have similar problems with older drivers,
see http://blog.chromium.org/2011/03/gpu-acceleration-old-drivers.html
"However, as we’ve rolled out features like WebGL and GPU-accelerated HTML5 video, we noticed a troubling trend: users with old graphics drivers experienced a significant increase in crashes when using these features."
It seems that it is still blocked for all ATI/AMD drivers and graphic cards ?
If yes can someone please check if this is still needed for v12.x drivers.
I think after over one year and new graphic cards it could be fixed by AMD.
Thanks
We might unblacklist OpenGL on recent AMD drivers soon, but it won't allow for really fast WebGL until AMD implements OpenGL-D3D surface sharing, which as far as we know is not currently happening, so this is not a high priority.
You need to log in before you can comment on or make changes to this bug.