talos needs to support environment variables on remote testing

RESOLVED FIXED

Status

Testing
Talos
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

Trunk
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile_unittests])

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

8 years ago
Created attachment 498207 [details] [diff] [review]
patch to bring device manager up to speed with mozilla central (1.0)

currently we need to disable crashreporter and this requires us adding environment variables into the command that we send to android. 

instead of:
'exec org.mozilla.fennec -profile /tmp/profile http://my/test.html'

it needs to be:
'exec "MOZ_CRASHREPORTER_NO_REPORT=1" org.mozilla.fennec -profile /tmp/profile http://my/test.html'
Attachment #498207 - Flags: review?(anodelman)
(Assignee)

Comment 1

8 years ago
Created attachment 498208 [details] [diff] [review]
support android style environment variables from the .config file (1.0)

secondary patch which fixes the talos code to support the environment variables on the command line which android needs.

These will be running on talos staging
Assignee: nobody → jmaher
Attachment #498208 - Flags: review?(anodelman)
(Assignee)

Comment 2

8 years ago
Created attachment 498336 [details] [diff] [review]
patch to bring device manager up to speed with mozilla central (1.5)

updated patch to fix a few devicemanager specific things.
Attachment #498207 - Attachment is obsolete: true
Attachment #498336 - Flags: review?(anodelman)
Attachment #498207 - Flags: review?(anodelman)
(Assignee)

Comment 3

8 years ago
Created attachment 498337 [details] [diff] [review]
support android style environment variables from the .config file (1.5)

moved stuff out of here into the devicemanager patch to keep it unique.  Also added in a new ENV variable that mobile supports as well as a cleanup on the run_tests.py application.ini discovery.
Attachment #498208 - Attachment is obsolete: true
Attachment #498337 - Flags: review?(anodelman)
Attachment #498208 - Flags: review?(anodelman)
(Assignee)

Comment 4

8 years ago
updated both patches.  The original patches were green on try!  I am running these new patches on try and we will see the results.  I will have to update the results in this bug this weekend as I will be AFK the majority of today.
Please update when you get a green run through so that I can complete my review.
Attachment #498336 - Flags: review?(anodelman) → review+
Attachment #498337 - Flags: review?(anodelman) → review+
Just a general comment that we may need to clean up in future the general case setting of env vars from the specific remote setting - instead of just having one thing called 'env' might be smarter to split into local_env and remote_env and then handle those things separately.  Could just become confusing when pretty much the same config file has different results depending on if you are running remote or not.
(Assignee)

Comment 7

8 years ago
as a note, these passed talos staging all green.
(Assignee)

Updated

8 years ago
Blocks: 620104
(Assignee)

Updated

8 years ago
Blocks: 620137
(Assignee)

Updated

7 years ago
Duplicate of this bug: 618182
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.