Default character encoding not used in newsgroups

VERIFIED DUPLICATE of bug 32714

Status

P3
normal
VERIFIED DUPLICATE of bug 32714
18 years ago
10 years ago

People

(Reporter: mozbug, Assigned: rhp)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
2000120420 trunk NT4 Sp6a

I have the default character encoding set in the prefs to ISO-8859-1 and
Auto-detect set Japanese.
Whenever I get a news message with no encoding set in the headers, it's rendered
using one of the Japanese encoding.
(Reporter)

Comment 1

18 years ago
Created attachment 20184 [details]
Source of the message
(Reporter)

Comment 2

18 years ago
Created attachment 20185 [details]
Picture of the rendered message

Comment 3

18 years ago
I am confirming this bug since the phenomenon described by
Gilles does occur. But I wonder if we should really fix this
problem. In the current spec for this, we honor
"Auto-detection" above the fallback encoding set in the
Pref | Message Display. If you want to have correct
display, you can check the "Apply the default to all
messages..." in the Pref for Message Display.

If this does not work, it would be a bug.

One possibility we can think of is to place the default
encoding higher than Auto-detection, however. CC'ing
nhotta and others. Let's think about this a bit before
deciding what to do.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: esther → momoi

Comment 4

18 years ago
>One possibility we can think of is to place the default
>encoding higher than Auto-detection, however.
No, it makes auto-detection useless.
For better newsgroup support, it is planned to be targeted by folder level
charset (bug 32714) feature. It will allow the user to set a particular charset
per newsgroup instead of a global default.

Comment 5

18 years ago
And then you can force that encoding for that folder
only -- in which case, auto-detection will be ignored.
Yes, that's a better solution.
Then, let's make this a duplicate of that bug.
Marking this a duplicate of Bug 32714.

*** This bug has been marked as a duplicate of 32714 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
We are going to verify this bug as a duplicate of Bug 32714.
Being able to "force" the per folder encoding onto
all the msgs in a given folder will solve the reported problem. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.