Last Comment Bug 619997 - Kill Document.renameNode
: Kill Document.renameNode
Status: RESOLVED FIXED
[wdc]
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-17 13:40 PST by :Ms2ger
Modified: 2011-04-21 13:45 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (3.53 KB, patch)
2011-03-09 08:00 PST, :Ms2ger
jonas: review+
Details | Diff | Review

Description :Ms2ger 2010-12-17 13:40:08 PST
Document.renameNode has never been implemented, and has been removed from Web DOM Core, we should remove it from the IDL as well. Patch coming up.
Comment 1 :Ms2ger 2011-03-09 08:00:08 PST
Created attachment 518065 [details] [diff] [review]
Patch v1

As promised.
Comment 2 Boris Zbarsky [:bz] 2011-03-30 10:22:19 PDT
Needs IID changes for things inheriting from nsIDOMDocument.
Comment 3 :Ms2ger 2011-04-16 05:46:31 PDT
http://hg.mozilla.org/mozilla-central/rev/4e6378990125

I don't think this needs an awful lot of docs, the only things that changed here is that document.renameNode === undefined and that document.renameNode() throws a different exception.
Comment 4 Eric Shepherd [:sheppy] 2011-04-21 13:45:11 PDT
Documentation updated by removing it renameNode from the list of methods here:

https://developer.mozilla.org/en/DOM/document

I'm not mentioning this on Firefox 6 for developers since the method was never implemented anyway.

Note You need to log in before you can comment on or make changes to this bug.