When viewing Add-ons Manager in full screen, captions buttons are not visible

VERIFIED DUPLICATE of bug 575516

Status

()

VERIFIED DUPLICATE of bug 575516
8 years ago
6 years ago

People

(Reporter: at.light, Unassigned)

Tracking

Trunk
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Reporter)

Description

8 years ago
The Add-ons Manager now hides the browser toolbars. However, this means that the caption buttons (Min, Max, Close) disappear too; in this case, there is no way to leave full-screen mode without pressing F11 (which some users will not know) or switching tabs (a non-obvious way of leaving full-screen mode).

STR:
1. Open Add-ons Manager
2. Press F11
 * No caption buttons visible
(Reporter)

Updated

8 years ago
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
blocking2.0: --- → final+
Summary: When viewing Add-ons Manager in full screen, captions buttons are not visible → When viewing Add-ons Manager in full screen, window controls are not visible
Looks like we would need an ui proposal from ux. CC'ing Jennifer.
Keywords: uiwanted
Most straightforward thing here is to just reveal the chrome as normal when in fullscreen. Unless UX come up with anything better (and easy to do) soon then we'll just have to go with that.
The standard behavior for fullscreen mode in other apps is to exit fullscreen when you press Esc. I suggest we do the same.
Another mitigating step could be to gray out the fullscreen menu when in the add-ons tab, but that might be bad to special-case.

I agree that fullscreen mode needs to be fixed up quite a bit, but for this particular edge case, I think it's fine as long as Esc gets you out, since we only have one instance of the toolbar-less UI for Firefox 4.
Keywords: uiwanted
Component: Add-ons Manager → General
Product: Toolkit → Firefox
Summary: When viewing Add-ons Manager in full screen, window controls are not visible → Firefox should exit full screen when pressing the Esc key
I think web content might be consuming the escape key, so doing this while content is focused might not be a good idea.

Also, I think we want the window controls regardless of what ESC does; we should probably move them to the tab bar (bug 598255).
That works for Windows, but on Mac we don't render the menu at all in fullscreen when you hit the edge of the screen (which I would consider a bug).
(In reply to comment #6)
> That works for Windows, but on Mac we don't render the menu at all in
> fullscreen when you hit the edge of the screen (which I would consider a bug).

It is indeed a bug: bug 620083
(In reply to comment #7)
> It is indeed a bug: bug 620083

That's the nav toolbar + tabs, not the menu, I think.
Yes, it's about toolbar + tabs, and that's also where the windows controls sit in full-screen mode.
(In reply to comment #9)
> Yes, it's about toolbar + tabs, and that's also where the windows controls sit
> in full-screen mode.

Not on OSX, we just don't show them at all.

Also if you understand what that bug report is about can you add some more information to it, I haven't been able to figure out what it is talking about yet.
(In reply to comment #10)
> (In reply to comment #9)
> > Yes, it's about toolbar + tabs, and that's also where the windows controls sit
> > in full-screen mode.
> 
> Not on OSX, we just don't show them at all.

We hide the minimize and exit buttons on OS X, the restore button is still there.
QA Contact: add-ons.manager → general
Depends on: 575516
Bug 575516 fixed this bug as originally filed.
(In reply to comment #12)
> Bug 575516 fixed this bug as originally filed.

Since the main issue is already resolved, it doesn't seem like this would even be a soft blocker anymore.

I disagree with mapping Esc to exit full screen mode. Esc has been mapped to Stop since Firefox 2 or earlier. While a page is loading in fullscreen mode, a keyboard shortcut user would expect pressing Esc to stop the load rather than exit full screen mode.
I'm not sure I agree that the ESC key should exit fullscreen either. At most, revealing the toolbar, though as Frank suggests, this is overloading the ESC key.

We might need better instructions (maybe a notification panel?) that tells the user what they've done when they hit F11 and explains how to get out of it. People should only need to learn this once or twice to get the hang of it.

I think this is a pillowy soft blocker.
Whiteboard: [pillowy][softblocker]
having said that, is there any consensus on what needs to be done for this bug?
I'm morphing this back and resolving it accordingly. Please file a new bug if for some reason we need ESC to exit full screen mode.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: Firefox should exit full screen when pressing the Esc key → When viewing Add-ons Manager in full screen, captions buttons are not visible
Whiteboard: [pillowy][softblocker]
Duplicate of bug: 575516
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.