Html5 video (ogg) shows black vertical lines when scaled

VERIFIED DUPLICATE of bug 616778

Status

()

Core
Audio/Video
VERIFIED DUPLICATE of bug 616778
7 years ago
7 years ago

People

(Reporter: pietro.brenna, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.0; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 5.0; rv:2.0b9pre) Gecko/20101218 Firefox/4.0b9pre

If an html5 video is scaled, either by CTRL - or in the web page with the html markup, in Windows 2000 black vertical lines appear.
This doesn't happen in Ubuntu 10.10 (it's another computer, I don't know if it is caused by hardware or software).
Graphics card: Radeon IGP 320m


Reproducible: Always

Steps to Reproduce:
1.Open html5 video
2.Ctrl -
Actual Results:  
Black vertical lines above video content

Expected Results:  
Scaled video

Comment 1

7 years ago
Please post the graphics section from about:support

Also, can you attach a screenshot showing the issue.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Please post the graphics section from about:support
> 
> Also, can you attach a screenshot showing the issue.

Adapter Description: RADEON IGP 320M
Vendor: ID1002
Device: ID4336
Adapter RAM: Unknown
Adapter Drivers: ati2dvag
Driver Version: 6.13.10.6218
Driver Date: 11-7-2002
Direct2D Enabled: false
DirectWrite Enabled: false
WebGL Renderer:(WebGL unavailable)
GPU Accelerated Windows: 0/1

It is definitely a software problem: I have tried the same thing on the same computer using Ubuntu 6.10 and it works. I'll soon attach the screenshot
(Reporter)

Comment 3

7 years ago
Created attachment 498589 [details]
Screenshot on Win 2000 sp4
I'm not sure if this is the same issue as bug 618458 or not, but in both cases it is related to scaling.
(Reporter)

Comment 5

7 years ago
(In reply to comment #4)
> I'm not sure if this is the same issue as bug 618458 or not, but in both cases
> it is related to scaling.

I can't help with code, but it could be related to bug 618458 as sometimes green parts appear too. I have encountered the same problem on Win Xp too.
To sum up:

2001 computer (radeon...) |  2009 computer (Mobile Intel (r) 4 Series Express)
******************************************************************************
Windows 2000: error       |  Ubuntu 10.10:  works
Windows XP:   error       |  Windows 7   :  works
Ubuntu 6.10:  works       |  Windows XP  :  works

Updated

7 years ago
Version: unspecified → Trunk
What CPU model does the computer have where you're seeing this problem?
(Reporter)

Comment 7

7 years ago
(In reply to comment #6)
> What CPU model does the computer have where you're seeing this problem?

Compaq, EvoN1015V
x86 Family 6 Model 8 Stepping 1 AuthenticAMD ~1656 MHZ
Thanks, that appears to be an Athlon XP (Thoroughbred B), which has support for MMX and SSE, so it should be using the SSE version of the colour conversion code.  Your paste of about:support earlier confirms that you're not using the hardware accelerated path for this.

I tested both the SSE and plain C (just in case we're falling back to C on your CPU) versions of the code on a Windows 7 machine (with HW acceleration disabled), but still failed to reproduce this problem.
From your original steps, it sounds like the video is playing when you hit Ctrl and - to scale the video.  Is that the case?  Does the corruption appear instantly at that point?  Starting from the first step, if you pause the video so that the current frame is not corrupt and then scale down with Ctrl and -, do you see corruption in that case?  If not, does it appear once you start playing the video?
Oh, this might be a duplicate of bug 616778, which is now fixed.  Can you please test the latest nightly build?
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> Oh, this might be a duplicate of bug 616778, which is now fixed.  Can you
> please test the latest nightly build?

You're right, now it works for me. Mark as resolved duplicate?
Thanks for confirming!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616778
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.