genxref function/get/set/let/const/var code need guards for the average case and regexp improvements

RESOLVED FIXED

Status

Webtools
MXR
--
blocker
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: philor, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
From last night:

[10:01pm] <justdave>: and the cron job has been stuck for 3 days 14 hours.
[10:02pm] <justdave>: on mozilla-central
[10:02pm] <justdave>:  6402  3-12:15:10  |  |                  \_ /usr/bin/perl /var/www/webtools/mxr/genxref /data/mxr-data/mozilla-central/mozilla-cen
...
[11:02pm] <justdave>: but yeah, mxr had hung jobs, I killed them off, and stuff should fix in a few hours

But 11 hours later, it still hasn't updated, according to my handy check of "does http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/tests/cpp/places_test_harness.h include the '#ifdef LINUX' which landed in it with http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=790de2a5e9f5 last Wednesday night?"

Updated

7 years ago
Assignee: server-ops → justdave
I believe this applies to comm-central as well.
(Assignee)

Comment 2

7 years ago
i think this is bug 614207.

justdave: to confirm this, you should be able to remove -cron from one of the update-xref.pl's (or from update-full-onetree.sh).

What you should see is it getting stuck at:

(Pass 1 JS) js/src/tests/js1_5/Regress/regress-229006.js (67973), file 3444 of 7277...

The stuff after file may vary a bit from tree to tree.
Depends on: 614207
Yep, we had jobs stuck again.  comm-1.9.1 is consistently one of them.  I'm running that one by hand without -cron right now to see what output I get.
(Assignee)

Comment 4

7 years ago
<justdave> (Pass 1 JS) mozilla/js/tests/js1_5/Regress/regress-229006.js (68010), file 2910 of 6182...
<justdave> that's the last line

justdave applied a patch for bug 614207 and it seemed to resolve the issue, so i pushed it.
(Reporter)

Comment 5

7 years ago
Still not updating, and somebody's going to land something busted based on an mxr search (and the odds favor it being me).
Severity: major → blocker
Which tree, specifically?
OK, I see hung processes again, all in the "projects-central" tree this time.  Killed them off, running that one by hand now to get debug output.
(Reporter)

Comment 8

7 years ago
mozilla-central, I'm still on comment 0, http://mxr.mozilla.org/mozilla-central/source/toolkit/components/places/tests/cpp/places_test_harness.h not having the #ifdef LINUX that was added by the Places branch merge on the evening of December 15th, since I very nearly slightly broke the tree on December 19th before I realized why my build wasn't quite acting like the stuff I was seeing in mxr.
timeless: looks like the same error in a different part of the tree.

projects-central dies on:
(Pass 1 JS) kraken/tests/kraken-1.1/ai-astar-data.js (466626), file 40771 of 52984...
(Assignee)

Comment 10

7 years ago
hrm. there's a line numbering change for js, lemme try to dig it out

Updated

7 years ago
Duplicate of this bug: 625084
timeless: anything else to try?  Getting complaints about this still.
(Assignee)

Comment 13

7 years ago
sorry, i was away for a wedding. lemme dig this up..
Duplicate of this bug: 630055
Whiteboard: [waiting for timeless?]
(Assignee)

Comment 15

7 years ago
ok, the kraken test and a working nytprof made my life much better.
Assignee: justdave → timeless
Status: NEW → ASSIGNED
Component: Server Operations → MXR
Product: mozilla.org → Webtools
QA Contact: mrz → mxr
Summary: mxr.mozilla.org hasn't updated for days → genxref function/get/set code test needs a guard for the average case
Whiteboard: [waiting for timeless?]
(Assignee)

Comment 16

7 years ago
ok, and running nytprof on the original problem case and then thinking about it a bit more, i think i got both of them to be not stupid.
Summary: genxref function/get/set code test needs a guard for the average case → genxref function/get/set/let/const/var code test need guards for the average case and regexp improvements
(Assignee)

Updated

7 years ago
Summary: genxref function/get/set/let/const/var code test need guards for the average case and regexp improvements → genxref function/get/set/let/const/var code need guards for the average case and regexp improvements
(Assignee)

Comment 17

7 years ago
http://hg.mozilla.org/webtools/mxr/rev/7452e0f4b050

please file a new bug with the path for the next unhappy file if you hit this again. oh, i'll want to remove the bandaid at some point.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
A fix, woot! Does it get auto-deployed to mxr.m.o or do we need a bug for that ?
(Assignee)

Updated

7 years ago
Blocks: 632643
You need to log in before you can comment on or make changes to this bug.