Closed Bug 620351 Opened 9 years ago Closed 9 years ago

The earthquakes in Nine Point Five don't work properly if methodjit is enabled

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 612334
mozilla2.0
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: spammaaja, Unassigned)

References

()

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101219 Firefox/4.0b9pre

The earthquakes Nine Point Five don't work properly in Minefield, but works in Chrome.

Error: invalid arguments
Source File: http://www.ninepointfive.org/static/nine5.js
Line: 9

Reproducible: Always
Version: unspecified → Trunk
You'll need to click the little "tour" button, which is the fourth button above "9,5".
Attached image On Minefield
NaN undefined
Attached image On Chrome (1)
Attached image On Chrome (2)
blocking2.0: --- → ?
Confirm.
The line of code mentioned in comment 0 is:

  var fa = new Float32Array(data.length / 6 * 8);

I guess that the problem is that length/6*8 is not integer and that this demo is relying on it to be rounded ?
That part was about us generating a warning when data.length == 0, we shouldn't, fixing this on our side.

The visual glitch seems to be unrelated, and a more far-reaching issue: from email conversation with the authors of this app: "The significant events (the sidebar with the list of top earthquakes) isn't working at all under Firefox.  Seems like the data isn't getting in, so there must be something happening in the JavaScript.  It works fine on SFX and v8."
So, the warning was not caused by length==0, it was caused by the length being non-integer, since division produces a floating-point value.
Please ignore comment 8 --- the warning is really related to length==0.
Is data.length not divisible by 3 here?  Or are we just seeing bug 612334?
Depends on: 612334
It works if I set javascript.options.methodjit.content to false.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: Canvas: WebGL → JavaScript Engine
Ever confirmed: true
QA Contact: canvas.webgl → general
Target Milestone: --- → mozilla2.0
And I confirmed that attachment 499220 [details] [diff] [review] of Bug 612334 fixed this in local build.
Summary: The earthquakes in Nine Point Five don't work properly → The earthquakes in Nine Point Five don't work properly if methodjit is enabled
blocking2.0: ? → betaN+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 612334
You need to log in before you can comment on or make changes to this bug.