context window keeps pop up after onmousedown

RESOLVED WONTFIX

Status

()

Core
Event Handling
P3
normal
RESOLVED WONTFIX
18 years ago
16 years ago

People

(Reporter: HJ, Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Using Mozilla build 2000113020 on WinNT4 Sp6

And this example:

document.onmousedown = function MouseDownTrap(evnt) {
   alert('evnt.which = '+evnt.which);
   return false;
}

The event is trapped. So the the lines must be ok. And it also works in Netscape
4.76. But the context menu is still displayed, if you keep pressing the mouse
button! That's so wrong!

Ok, you may think, what's the point of trapping the mouse buttons?
Small question for you: Do you have a site for disabled people?
How in the world do the move a mouse device?
Get my point? I sure hope so.

Counting on you to confirm this typo! And come on people fix this!

Friendly, HJ
Worksforme linux build 2000-12-05-08.  event gets trapped and there is no
context menu
Created attachment 20223 [details]
HTML to test the event trapping

Comment 3

18 years ago
Confirm on mozilla trunk build 2000-12-04-04/win2k that the context menu is
displayed on right click with the alert inside the event handler and with it
removed.

I tested the attached page using IE 5.5 as well. Since IE has no evt.which, I
changed the alert to alert('hi').  With the alert in IE does not display the
context menu on right click, but with the alert removed IE displays the context
menu.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

18 years ago
For checks with with MS Internet Explorer this would do the trick:

document.onmousedown = function MouseDownTrap(evnt) {
   alert('evnt.botton = '+evnt.button);
   return false;
}

Comment 5

18 years ago
See also bug 40535, which would make the alert not pop up until after the 
context menu goes away.

Comment 6

18 years ago
This one seems to be assigned to joki, hey joki, I don't know your name nut can
you please at least reply on this one! Tnx.

Comment 7

18 years ago
Keep pressing that mouse button, then you will see the menu context menu!
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
(Assignee)

Comment 9

18 years ago
The reason that this doesn't work is that the context menu is now fired on the 
mouseup, not the mousedown.  This was a UI decision which was made that 
supposedly makes the browser more in tune with UI guidelines.  IE also 
works this way, though I was unable to cancel their context menu.  Anyway, since 
the menu comes up based on the mouseup, canceling the mousedown event is 
unrelated.  Canceling the mouseup event does work.  Yes this is a change from 
4.x but it was done at the behest of the UI guys.

I'm going to mark this wontfix since the fact that this is a digression from 4.x 
makes it valid but we're not planning on returning to the 4.x model for context 
menu firing.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX

Updated

17 years ago
Depends on: 49844

Comment 10

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.