Closed Bug 620489 Opened 14 years ago Closed 14 years ago

Feature Request: Windows 7 Pinned Sites API

Categories

(Firefox :: Shell Integration, enhancement)

x86_64
Windows 7
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 605222

People

(Reporter: me, Unassigned)

References

()

Details

(Whiteboard: [DUPEME])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 ( .NET CLR 3.5.30729; .NET4.0C)

I think this new integration with Windows 7 is a fantastic feature of the Internet Explorer 9 beta, and I would love to see Firefox support it. It would need support for meta elements to define tasks in the jump list, and the JavaScript API for defining Jump List categories, icon overlays, etc. These are detailed here: http://msdn.microsoft.com/en-us/library/gg131029(VS.85).aspx

Reproducible: Always

Steps to Reproduce:
1. Open a website with Pinned Site support
2. Drag the Favicon to the Windows 7 Taskbar
Actual Results:  
No custom Jump Lists or Pinned Sites are created.

Expected Results:  
It should pin a site to the taskbar with the icon specified by the <meta> tag, give it a custom jump list specified by <meta> tags, and interact with the website via the JavaScript API.
Blocks: win7support
Status: UNCONFIRMED → NEW
Ever confirmed: true
Pretty sure this was already filed
Whiteboard: [DUPEME]
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.