Incorrect handling of onmouseover event while left mouse button is down. Actual for divs with "overflow:hidden" style.

RESOLVED DUPLICATE of bug 1352061

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 1352061
7 years ago
13 days ago

People

(Reporter: Andrei, Unassigned)

Tracking

(Blocks: 1 bug)

1.9.2 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.10 (maverick) Firefox/3.6.13

The idea is to press on one of the divs and then mark all other divs moving mouse over them holding the left mouse button down.

The first click calls a function that sets variable mousedown=true and marks the div. Then moving mouse over other divs calls a onmouseover event that checks if mousedown is true and, if so, it marks these divs too.

It works great, but setting overflow:hidden fot these div break the functionality. Was checked under FF 3.6.13 under Windows 7 x64 and Kubuntu 10.10 x86_64.

There are 2 links at http://dimengine.ru/ to check the issue.

Reproducible: Always

Steps to Reproduce:
1. Follow one of the links at http://dimengine.ru/
2. Press left mouse button on one of the divs.
3. Hold the button and move mouse over other divs.
Actual Results:  
onmouseover event isn't handled while overflow:hidden is set

Expected Results:  
All divs should be marked black in both cases
Component: General → Event Handling
Product: Firefox → Core
QA Contact: general → events
Version: unspecified → 1.9.2 Branch
Things with non-visible overflow capture the mouse, no?  That's the expected behavior in Gecko, last I checked....
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Things with non-visible overflow capture the mouse, no?  That's the expected
> behavior in Gecko, last I checked....

All elements of the page are visible. Mouse capturing can't be expected in this case. It breaks multiselect functionality.

Comment 3

6 years ago
Experienced the same issue. Having to rework the codebase to correct this bug.
Blocks: 1361430

Comment 4

13 days ago
Dup to bug 1352061 for identical symptom. Also comment 0 link is unavailable now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1352061
You need to log in before you can comment on or make changes to this bug.