Last Comment Bug 620756 - Properly check the nsIScriptError flags
: Properly check the nsIScriptError flags
Status: RESOLVED FIXED
[console-1][good first bug]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Brian Grinstead [:bgrins]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-21 12:01 PST by Mihai Sucan [:msucan]
Modified: 2012-08-20 09:03 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mihai Sucan [:msucan] 2010-12-21 12:01:18 PST
(followup from bug 613364)

In logConsoleActivity() we do not properly check the nsIScriptError object flags property, we don't check the bits, we just check the whole value against a hash of known flag values.

We need to fix the code and do proper flag checking.
Comment 1 Abhishek Potnis [:avp] 2012-08-19 05:57:47 PDT
Hi All,

I would like to work on this bug. Can someone please guide me on getting started with this bug ?

Thanks.
Comment 2 Mihai Sucan [:msucan] 2012-08-19 07:25:06 PDT
Hello Abhishek. Thanks for your interest. This bug needs to be re-evaluated by us. It may no longer be valid since we changed the Web Console implementation a lot.
Comment 3 Mihai Sucan [:msucan] 2012-08-20 09:03:54 PDT
This bug has been fixed by some other patch. I can't quickly find where, in which bug.

Note You need to log in before you can comment on or make changes to this bug.