If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Allow CSS |content| property to apply to non-generated content

RESOLVED DUPLICATE of bug 215083

Status

()

Core
CSS Parsing and Computation
--
enhancement
RESOLVED DUPLICATE of bug 215083
7 years ago
4 years ago

People

(Reporter: Pierre Rudloff, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.2.14pre) Gecko/20101214 Camino/2.1a1pre (like Firefox/3.6.14pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; fr; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Opera seems to be the only browser to support this kind of code :
img#myImage:hover{
   content:url('myImage.png');
}

I don't know if it is part of the spec but I could be quite useful to dynamically change an image without using JavaScript.

Reproducible: Always

Actual Results:  
Nothing.

Expected Results:  
The image is replaced by another one.
It's not in the current specs, no.  There have been some proposals for a CSS3 Generated Content module that might have allowed doing this, but they seem to have been abandoned.
Component: Layout: View Rendering → Style System (CSS)
QA Contact: layout.view-rendering → style-system
Summary: CSS generated content on :hover pseudo-class → Allow CSS |content| property to apply to non-generated content
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 215083

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.