mozilla gets confused trying to go to a different site

RESOLVED DUPLICATE of bug 42453

Status

()

Core
Networking: Cache
P3
major
RESOLVED DUPLICATE of bug 42453
18 years ago
17 years ago

People

(Reporter: Kendric Beachey, Assigned: neeti)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (WinNT; U ;Nav)
BuildID:    2000120308 (actually all builds for the last month or so)

I tried to scan for this in the bugs already out there, but I can barely figure 
out how to describe the problem in any succinct way, so I didn't really know 
what to search for.  So if this is a duplicate, just knock it out.

Anyway: going to a site other than the one I'm at has been really tough for 
mozilla for the past month or so.  If this is happening for youse guys at 
mozilla.org, you doubtless already know what I'm talking about.  In case you 
don't, here's an example.

Mozilla wakes up pointing to my home site, which is on our company intranet, 
called something like http://blahblah/dir1/dir2/file.html, and after that I try 
to go somewhere else, say my.netscape.com.  Sometimes this works, but sometimes 
mozilla tries to mix the urls, coming up with something like 
http://my.netscape.com/dir1/dir2/file.html, which of course doesn't work.  
Usually, manual editing of the url and re-submission clears this up, if not on 
the first try then on the second or third.

Or, once I've managed to get to my.netscape.com (for example), I'll click on a 
link that goes somewhere else, www.32bitsonline.com for example, but where I end 
up is the non-personalized version of my.netscape.com.  Or home.netscape.com.  
Or linuxtoday.com, which I visit a lot as a rule, but in my example I haven't 
gone there yet during this session.

Or, sometimes I get to a site successfully, read over it, and then hit the back 
button to return to the previous site, and the correct url appears in the 
location bar, but the same site re-loads itself instead.  To use the same sort 
of example, I go to my.netscape.com, follow a link to www.32bitsonline.com, then 
hit the back button, and the location bar says my.netscape.com but the browser 
window loads www.32bitsonline.com again instead.

I wish this was easy to reproduce, but it only happens about 20% of the time, 
and it usually seems to be the worst at the beginning of a session.  Sometimes 
it's so bad that it never gets to the place I'm trying to go, and I just quit 
and restart.  But sometimes it just seems to have to go through a few of these 
episodes, and then it snaps out of it and it's pretty much fine for the rest of 
the session.

I would be remiss if I didn't mention that I'm browsing from behind a firewall 
that I curse on a regular basis, on account of its being a slow piece of 
doo-doo.  I don't know what kind of brain-damaged algorithms are going on at the 
firewall level, whether some goofy caching mechanism is at work or whatever.  
But I do know that it's only mozilla that exhibits this behavior; Netscape 4.x 
works fine.  And even mozilla worked fine until about M18 or so.  So it may not 
be the firewall, but I thought you might want to know it was there.
Kendric, could you try to reproduce these problems with a fresh profile? Thanks!

Comment 2

18 years ago
Strange, I've had no such problems on Linux and WinNT/2000 and I download
nightly builds on a frequent basis. I've used in both directly connected to the
internet and through a HTTP proxy. Are you able to try the builds on another
machine to see if you have the same problems? What happens if you just stay
within the corporate intranet (which I assume is not behind the firewall)?
(Reporter)

Comment 3

18 years ago
I knocked out my mozilla profile (winnt\moz*.* and
winnt\profiles\me\applicationdate\mozilla\*.*) and created a new profile the
next time I ran mozilla, by having it convert my 4.x profile.  The same problems
still happen.

David, yes, stuff on our intranet seems to work okay, or at least I haven't seen
the problem yet.

Here's another example while I'm at it:  I opened mozilla, which went to our
intranet start page, then I went to my.netscape.com, then I followed a link to
my page on my ISP (http://www.sound.net/~ak), then hit the back button.  The url
said my.netscape.com but the url it really went to in the browser window was
www.sound.net (the base site, not my directory on their site).  Could this be
some freaky IP caching behavior?  Like I said, 4.x doesn't do this stuff, nor
does IE, so while our firewall does suck, I don't think it's probably the
culprit this time.

Comment 4

18 years ago
If you go to preferences, Advanced, Networking and change HTTP 1.1 to HTTP 1.0
If that fixes this then you're seeing bug 38488.
(Reporter)

Comment 5

18 years ago
I changed the http version to 1.0 as directed and it had no effect.  Dang!  
(BTW, http version was under Debug, not Advanced.)

Comment 6

17 years ago
over to Networking
Assignee: asa → neeti
Component: Browser-General → Networking
QA Contact: doronr → tever

Comment 7

17 years ago
This might have to do with bug 42453. Not sure though....There is another bug
out there with a similar problem to this but i cant even remember what its
called. Going to try and dig it up.

Reporter is this still occuring with the latest nightlies?
(Reporter)

Comment 8

17 years ago
The nightly from 18 Dec 2000 still shows the same misbehavior.
(Reporter)

Comment 9

17 years ago
After looking at bug 42453, this could be some of the same stuff, although for 
me it takes much less gyration to produce the bug, when it's in the mood to 
happen.  I am a little startled to see so much discussion of this stuff way back 
in June, when for me it never happened until, oh, November or so.  Also, the 
folks discussing on 42453 seem to be primarily using Linux, whereas I'm on win32 
here at work.  (On Linux at home I haven't tried mozilla in a while; maybe I 
should.)

I should point out, perhaps, that most of the time, no amount of doing "reload", 
or "shift+reload", or clearing cache and trying again, will help.  But sometimes 
I am able to try hitting a site by an alternate name and get good results.  For 
example, if mozilla is going to the wrong place every time I try to go to 
www.linuxtoday.com, sometimes I can get there by instead trying for 
linuxtoday.com, no www on the beginning.

Comment 10

17 years ago
I am going to go ahead and mark this NEW. Call me crazy but I cant figure it out.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 11

17 years ago

*** This bug has been marked as a duplicate of 42453 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Component: Networking → Networking: Cache
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

17 years ago
I'm still not entirely sure that the causes of this bug and bug 42453 are the 
same; however, I have resigned myself to several things:

1) This problem only happens on my machine at work, and does not happen (that I 
have heard) for any of my co-workers.
2) The guys that set up our machines and our software at work are not the 
brightest armadillos on the road, and our configurations often have odd problems 
with no clear cause.
3) Everything works great at home on Linux.
4) I expect not to be at this job much longer.  After I am gone, I would imagine 
this machine will be re-imaged, thus wiping out whatever crossed-up situation is 
currently in place.  Problem solved.  Plus, at my new job, I will hopefully be 
able to start from scratch.  Yay me!  :-)

So, what with all that, it won't bother me much if this bug never gets 
officially solved.
You need to log in before you can comment on or make changes to this bug.