Closed Bug 620811 Opened 9 years ago Closed 9 years ago

Crash on restarting fennec

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

ARM
Android
defect
Not set
blocker

Tracking

(fennec2.0b3+)

VERIFIED FIXED
Tracking Status
fennec 2.0b3+ ---

People

(Reporter: tchung, Assigned: blassey)

References

Details

(Keywords: regression, Whiteboard: [4.0b3])

Attachments

(1 file, 1 obsolete file)

It easily crashes and opens the android crash reporter when restarting fennec.  Error dialog thrown says: "Sorry The application Firefox (process org.mozilla.firefox) has stopped unexpectedly.  Please try again."

Repro:
1) install Fennec 4 beta 3 (build 2)
2) launch and add an addon, or toggle the beta tools error console
3) Click Restart button to continue
4) Verify Crash

Expected:
- no crash, restart successful.  AppID change regression

Actual:
- crash
- resta
tracking-fennec: --- → ?
Confirmed on the Nexus One, same STR.
When I enabled the Error Console I crashes, no crash report but I have seen a bug filed for that before.
ADB reports:

12-21 16:40:08.300 11601 11609 I GeckoAppJava: scheduling restart
12-21 16:40:08.300 11601 11609 I GeckoAppJava: XRE exited
12-21 16:40:08.331 11601 11609 I GeckoAppJava: Intent { act=org.mozilla.gecko.restart flg=0x18000000 cmp=org.mozilla.firefox/.Restarter (has extras) }
12-21 16:40:08.354  1258  1258 I ActivityManager: Starting activity: Intent { act=org.mozilla.gecko.restart flg=0x18000000 cmp=org.mozilla.firefox/.Restarter (has extras) }
12-21 16:40:08.362 11601 11609 D dalvikvm: threadid=9: thread exiting, not yet detached (count=0)
12-21 16:40:08.393 11601 11601 D PhoneWindow: couldn't save which view has focus because the focused view org.mozilla.gecko.GeckoSurfaceView@45872b10 has no id.
12-21 16:40:08.409 11601 11601 I GeckoApp: pause
12-21 16:40:08.432 11601 11601 D AndroidRuntime: Shutting down VM
12-21 16:40:08.432 11601 11601 W dalvikvm: threadid=1: thread exiting with uncaught exception (group=0x400208b0)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: FATAL EXCEPTION: main
12-21 16:40:08.464 11601 11601 E AndroidRuntime: java.lang.RuntimeException: Unable to instantiate activity ComponentInfo{org.mozilla.firefox/org.mozilla.firefox.Restarter}: java.lang.ClassNotFoundException: org.mozilla.firefox.Restarter in loader dalvik.system.PathClassLoader[/data/app/org.mozilla.firefox-1.apk]
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2659)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2753)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread.access$2500(ActivityThread.java:129)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2107)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.os.Handler.dispatchMessage(Handler.java:99)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.os.Looper.loop(Looper.java:143)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread.main(ActivityThread.java:4701)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at java.lang.reflect.Method.invokeNative(Native Method)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at java.lang.reflect.Method.invoke(Method.java:521)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:868)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:626)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at dalvik.system.NativeStart.main(Native Method)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: Caused by: java.lang.ClassNotFoundException: org.mozilla.firefox.Restarter in loader dalvik.system.PathClassLoader[/data/app/org.mozilla.firefox-1.apk]
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at dalvik.system.PathClassLoader.findClass(PathClassLoader.java:243)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:573)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at java.lang.ClassLoader.loadClass(ClassLoader.java:532)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.Instrumentation.newActivity(Instrumentation.java:1021)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2651)
12-21 16:40:08.464 11601 11601 E AndroidRuntime: 	... 11 more
12-21 16:40:08.487  1258  4507 W ActivityManager:   Force finishing activity org.mozilla.firefox/.Restarter
12-21 16:40:08.987  1258  1270 W ActivityManager: Activity pause timeout for HistoryRecord{46251750 org.mozilla.firefox/.Restarter}
12-21 16:40:14.003 11601 11601 I Process : Sending signal. PID: 11601 SIG: 9
12-21 16:40:14.057  1258  1497 I ActivityManager: Process org.mozilla.firefox (pid 11601) has died.
Attached patch patch (obsolete) — Splinter Review
this should fix the restart crash. Looks like there's more that we need to do to fix crash reporting though
tracking-fennec: ? → 2.0b3+
Attachment #499197 - Flags: review+
Attached patch patchSplinter Review
Assignee: nobody → blassey.bugs
Attachment #499197 - Attachment is obsolete: true
Attachment #499203 - Flags: review?(mwu)
Comment on attachment 499203 [details] [diff] [review]
patch

The "org.mozilla." string before ANDROID_PACKAGE_NAME needs to be removed and MOZ_APP_NAME should probably also be removed. r+ with this and testing.
Attachment #499203 - Flags: review?(mwu) → review+
Duplicate of this bug: 620813
pushed https://hg.mozilla.org/mozilla-central/rev/b7643182c67d and https://hg.mozilla.org/mozilla-central/rev/3cf00724041d
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified using the build3 candidates on an HTC Glacier (myTouch 4g); I've installed a couple of add-ons, restarted and the application does not crash. I've also enabled the error console, restarted, and the application does not crash either.
Also verified build 3 on the nexus one.  in addition to comment 9, i've tested notifications, alerts, and downloads.   No crashes.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.