Closed Bug 620889 Opened 12 years ago Closed 12 years ago

Unknown cause: Resource.get failure in bookmarks

Categories

(Cloud Services :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 618403

People

(Reporter: rnewman, Assigned: rnewman)

References

Details

Attachments

(1 file)

User is running a custom server, and has apparently done some fiddling of profile data, but I'm still investigating.

I added some extra logging and gave him a new addon. See attached.

Marking as confidential: user data.
Blocks: 621048
Comment on attachment 499245 [details]
Detailed log of failure.

>2010-12-22 08:10:19	Engine.Bookmarks     TRACE	Incoming: { id: -1btcOGuLEeP
>  index: 0
>  modified: 1292618669.58
>  payload: {"id":"-1btcOGuLEeP","type":"separator","parentName":"System Administration","pos":14,"parentid":"oBpSvZWRxquI"}
>  collection: bookmarks }
...
>2010-12-22 08:10:19	Service.Main         DEBUG	bookmarks failed: NS_ERROR_ILLEGAL_VALUE JS Stack trace: Res_get()@resource.js:383 < SyncEngine__processIncoming()@engines.js:511 < _processIncoming()@bookmarks.js:213 < ()@engines.js:203 < SyncEngine__sync()@engines.js:768 < wrappedSync(null)@util.js:172 < batchedSync()@util.js:178 < ()@engines.js:203 < WrappedNotify()@util.js:151 < Engine_sync()@engines.js:213 < WeaveSvc__syncEngine([object Object])@service.js:1796 < ()@service.js:1682 < WrappedNotify()@util.js:151 < WrappedLock()@util.js:119 < _lockedSync()@service.js:1587 < sync()@service.js:1572 < (1)@sync.js:380

I'm pretty sure NS_ERROR_ILLEGAL_VALUE isn't thrown by Resource.get() but by the bookmarks engine trying to add that record. Why exactly it's failing is hard to tell, but for separators there aren't that many entry points:

    case "separator":
      newId = this._bms.insertSeparator(record._parent,
                                        Svc.Bookmark.DEFAULT_INDEX);
      this._log.debug(["created separator", newId, "under", record._parent]
                      .join(" "));
      break;
    ...
    }

    this._log.trace("Setting GUID of new item " + newId + " to " + record.id);
    this._setGUID(newId, record.id);


We're not seeing the two log messages so I'm guessing the parentid didn't resolve correctly and we're failing on insertSeparator().
This should probably get duped (to Bug 618403?); I believe our pending changes to bookmarks fix this.
(In reply to comment #2)
> This should probably get duped (to Bug 618403?); I believe our pending changes
> to bookmarks fix this.

Yep.
Depends on: 618403
Pretty sure bug 618403 fixed this.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Group: mozilla-corporation-confidential
You need to log in before you can comment on or make changes to this bug.