Popup notification button size is off when DirectWrite is disabled

RESOLVED FIXED in mozilla2.0b9

Status

()

Toolkit
Themes
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Maciej Adamczak, Assigned: dao)

Tracking

unspecified
mozilla2.0b9
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

3.57 KB, patch
neil@parkwaycc.co.uk
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101221 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9pre) Gecko/20101221 Firefox/4.0b9pre

Split button wrong size with d2d disable:
http://img257.imageshack.us/img257/4269/withoutdirect2d.png
And enabled:
http://img821.imageshack.us/img821/530/withdirect2d.png
(also notice different sizes of browser UI elements)

Reproducible: Always

Steps to Reproduce:
1. Enter about:config
2. Switch gfx.direct2d.disabled setting.
3. Restart browser.
Whiteboard: dupeme
(Assignee)

Updated

8 years ago
Assignee: nobody → dao
Status: UNCONFIRMED → ASSIGNED
Component: General → Themes
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: general → themes
(Assignee)

Updated

8 years ago
Blocks: 577928
Summary: Arrowpanel/doorhanger wrong spit button size (direct2d) → Popup notification button size is off when DirectWrite is disabled
Whiteboard: dupeme
(Assignee)

Updated

8 years ago
blocking2.0: --- → ?
(Assignee)

Comment 1

8 years ago
Created attachment 500657 [details] [diff] [review]
patch
Attachment #500657 - Flags: review?(gavin.sharp)
blocking2.0: ? → final+
(Assignee)

Updated

8 years ago
Attachment #500657 - Flags: review?(neil)

Comment 2

8 years ago
Comment on attachment 500657 [details] [diff] [review]
patch

This looks reasonable for Windows Classic and Linux, which is all I can test.

>   .popup-notification-menubutton > .button-menubutton-button {
>-%ifdef WINSTRIPE_AERO
>-    padding: 0;
>-%else
>-    padding: 2px 0;
>-%endif
>+    padding-top: 0;
>+    padding-bottom: 0;
[Possibly this can go, since I can't seem to find any existing padding.]
Attachment #500657 - Flags: review?(neil) → review+
(Assignee)

Updated

8 years ago
Attachment #500657 - Flags: review?(gavin.sharp)
(Assignee)

Comment 3

8 years ago
> >   .popup-notification-menubutton > .button-menubutton-button {
> >-%ifdef WINSTRIPE_AERO
> >-    padding: 0;
> >-%else
> >-    padding: 2px 0;
> >-%endif
> >+    padding-top: 0;
> >+    padding-bottom: 0;
> [Possibly this can go, since I can't seem to find any existing padding.]

true!
(Assignee)

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/c64b948c1b9c
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b9
You need to log in before you can comment on or make changes to this bug.