Closed Bug 620995 Opened 12 years ago Closed 12 years ago

Sync UI: Clicking on TOS/PP checkbox does not enable Continue button on OS X

Categories

(Firefox :: Sync, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: Atoll, Assigned: philikon)

References

Details

(Whiteboard: [has patch][needs review mconnor])

Attachments

(2 files)

Steps on 4.0b8 on OS X:

1. Set Up Firefox Sync.
2. Create a New Account.
3. Enter email address, both passwords, and check the "I agree" box.
BUG: The Continue button is not enabled.  No amount of waiting helps.

At this point, if you Cmd-Tab to another application and then back, the button is enabled.
I'm sorry, I just checked and it looks like this wasn't 4.0b8, it was Minefield 4.0b9pre 2010-12-21.
I cannot reproduce this at all:

1. Set Up Firefox Sync -> Create New Account
2. Enter email address
3. Enter password
4. Confirm password
5. Check "I agree box" --> Continue button is enabled.
Attached video video of the bug
still occurs for me on latest Minefield 2010-12-22.
11:33:54 <@rnewman> atoll: I've seen 620995; the other day, coincident with me asking about staging being down
11:34:02 <@rnewman> worked on next try
11:34:14 < atoll> i can repro any time on one computer so far
11:34:33 <@rnewman> theory:
11:34:44 <@rnewman> I also saw that problem when I had a JS problem in my m-c tree
11:34:51 <@rnewman> calling a non-existent validation function
11:35:02 < atoll> be sure to update the bug with this
11:35:05 <@rnewman> you should be able to see the error in the error log or the terminal from which you launched firefox-bin
Actually, I think I know what's up. Clicking on the actual checkbox itself does not enable the Continue button. Clicking on its label does. We might have a bug for this already, we might not.

I have no idea what rnewman is going on about in comment 4, but I believe what atoll is seeing is the clicking-on-checkbox-rather-than-label.
More specific steps to reproduce:

1. Open a new Set Up Firefox Sync dialog.
2. Enter email address, then press Tab.
3. Enter password #1, then press Tab.
4. Enter password #2, DO NOT PRESS TAB.
5. Click the center of the square checkbox.
BUG: Continue not enabled.

If you pressed Tab at #4 by accident, you'll have to close out the entire setup dialog and start over from #1.

Steps that do NOT reproduce the bug:


1. Open a new Set Up Firefox Sync dialog.
2. Enter email address, then press Tab.
3. Enter password #1, then press Tab.
4. Enter password #2, then press Tab
5. Click the center of the square checkbox.
WORKS: Continue is enabled.

My theory is that pressing Tab after password #2 sends a "done editing" event, where clicking on the checkbox does not, and so since the password isn't done being edited, the comparison isn't triggered, and the continue button remains locked.
tldr summary: The only difference between "it works" and "it is broken" is whether or not I press Tab at step #4 in comment #6.
(In reply to comment #5)
> Actually, I think I know what's up. Clicking on the actual checkbox itself does
> not enable the Continue button. Clicking on its label does. We might have a bug
> for this already, we might not.
> 
> I have no idea what rnewman is going on about in comment 4, but I believe what
> atoll is seeing is the clicking-on-checkbox-rather-than-label.

Clicking the label actually moves the blue focus ring, where clicking the checkbox alone does not.  Fixing that would probably coincidentally fix the Continue button bug.
(In reply to comment #6)
> My theory is that pressing Tab after password #2 sends a "done editing" event,
> where clicking on the checkbox does not, and so since the password isn't done
> being edited, the comparison isn't triggered, and the continue button remains
> locked.

Precisely.

(In reply to comment #8)
> Clicking the label actually moves the blue focus ring, where clicking the
> checkbox alone does not.  Fixing that would probably coincidentally fix the
> Continue button bug.

Bang on.
blocking2.0: --- → ?
blocking2.0: ? → beta9+
As per today's meeting, beta 9 will be a time-based release. Marking these all betaN+. Please move it back to beta9+ if you believe it MUST be in the next beta (ie: trunk is in an unshippable state without this)
blocking2.0: beta9+ → betaN+
Summary: Continue button not enabled in Sync Setup dialog → Sync UI: Clicking on TOS/PP checkbox does not enable Continue button on OS X
Attached patch v1Splinter Review
yo dawg i herd you liek xul
Assignee: nobody → philipp
Attachment #501224 - Flags: review?(mconnor)
Whiteboard: [has patch][needs review mconnor]
Fixing fields my automated script accidentally blanked. Apologies for the bugspam
Comment on attachment 501224 [details] [diff] [review]
v1

So the problem here is that checkFields is just checking the array of the various fields to see if each individual credential piece has been validated.  Another, possibly less hacky, fix is to have a "force" param on checkFields to call the validation functions for anything claiming to be invalid.

Manual focusing works, but ew.
Attachment #501224 - Flags: review?(mconnor) → review+
http://hg.mozilla.org/mozilla-central/rev/9ae61e07c2c6
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.