If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<iframe> % height doesn't work unless containing block has fixed height or is body.

VERIFIED DUPLICATE of bug 41656

Status

()

Core
Layout: HTML Frames
P3
normal
VERIFIED DUPLICATE of bug 41656
17 years ago
17 years ago

People

(Reporter: ekrock's old account (dead), Assigned: Eric Pollmann)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
[ Copied from N6 user feedback groups. ] I reproduced this using N6 11/8 on
WinNT 4.0. Compare above URL in IE 5.5 SP1 and N6 RTM to see problem.

Do we have an IFRAME support problem, or is his markup somehow IE-specific?

Operating System: 	WinNT
Language: 		English
Issue Summary: 		<iframe> doesn't work
Component: 		PageLayout
Doing What: 		Browing web pages
Severity: 		SomethingDidNotWorkRight
Can Reproduce: 		Always
Try this URL: 		http://www.rnix.com/home
Issue Detail:
<iframe> tags does render properly in the NS
6.0.0.20001108

Comment 1

17 years ago
Created attachment 20271 [details]
Testcase

Updated

17 years ago
Keywords: testcase

Comment 2

17 years ago
Created attachment 20273 [details]
Sample test of a iframe in a table

Comment 3

17 years ago
Based on the test provide, the probelm occurs if the iframe is in a table AND
has been assigned a % value for the width and height values. 

Comment 4

17 years ago
Yes, the substantial problem is that the height 100% causes the IFRAMEs to 
disappear. Duplicate of bug 41656.
(Assignee)

Comment 5

17 years ago
Thanks Richard, I agree that this is a duplicate.  The problem is only with
height, and only with iframes, which have no "intrinsic height" to fall back on
if they can't calculate an exact value.  I think Chris Karnaze has a fix for
this bug that might be acceptable now that we have shipped 6.0.

*** This bug has been marked as a duplicate of 41656 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Summary: <iframe> doesn't work compatibly with IE 5.5 SP1 on Win NT → <iframe> % height doesn't work unless containing block has fixed height or is body.

Comment 6

17 years ago
verifying as a duplicate of  41656
'(table/iframe) % height NOT ignored in block with no height specified'
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.